Support » Plugin: Fast Secure Contact Form » Error 500 – PHP Warning: A non-numeric value encountered

  • Resolved piglesias

    (@piglesias)


    Hi there!

    After upgrading to PHP 7.1.4 from a PHP5 version under IIS, we’re retrieving a 500 error at the plugin configuration page due to several issues in si-contact-form\includes\class-fscf-options.php

    After tracing the issue we have found this:

    `PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1061
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1146
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1148
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1222
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1223
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1227
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1229
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1231
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1233
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1235
    PHP Warning: A non-numeric value encountered in D:\wwwroot\WordPress\wp-content\plugins\si-contact-form\includes\class-fscf-options.php on line 1237`

    Well, don’t really know how to handle this ¯\_(ツ)_/¯ And downgrading would be a mess.

    Has anyone ever experienced something like this?

    We are using WordPress 4.7.5 and FSC Contact Form 4.0.50 (are the latest versions).

    Thank you!

    Best

    Pablo

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.