Support » Plugins and Hacks » [Resolved] Error 404

[Resolved] Error 404

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Eric Mann


    You might need to flush your permalinks.

    Navigate to Settings >> Permalinks in WordPress. You don’t need to save anything, just visit that page.

    I am having the same issue, and I have flushed the permalinks (several times). I am working on my site, and every time I add or update a plugin, the wp publications quit working.

    Simply visiting the permalinks doesn’t seem to flush them, so the archive works again. If I go to the permalinks and change it to the default, they work fine. Then I change back to my custom structure /%category%/%postname%, sometimes they will work, sometimes not. I may have to repeat this process several times to get it to stick.

    I love the archive and the way it looks and works (when it does). Hopefully we can get this fixed so that the permalinks stay put through changes.



    I’m having the same issue. I’ve looked at the code, trying to find what could be wrong, but it all seems to be in order. I have no idea what to do to fix it.

    I have flushed the permalinks more than once and it doesn’t work either.

    The site is in portuguese, but I was careful not to let the language break the code.

    Here’s an exemple of what’s going on: http://cac-uerj.com.br/publicados/fernandes/

    Every “Open” or “Download” link loads the 404 error.



    Plugin Author Eric Mann


    There is a pending update that will (hopefully) fix this issue. Stay tuned …

    Thanks in advance

    Appreciate this 404 problem may be fixed in a new update but I can’t wait. My site is not working properly and I know people can download the files ok but it doesn’t look too good.

    I really like this plugin and don’t want to change but does anyone know of any others that are similar and don’t break as much?


    I switched to: http://wordpress.org/plugins/download-manager/

    Quite helpful replacement plugin.

    Hope this helps.

    I have the same issue, permalink set and update to %postname% but not working :-/ I will go out. May be to the WordPress Download Manager http://wordpress.org/plugins/download-manager/


    Plugin Author Eric Mann


    I’ve just released version 3.0 of the plugin that contains significant improvements to the download system. Please update, flush your permalinks, then let me know if anything else breaks.

    I have the same problem with ver 3.0.1
    flushing permalinks does not work.

    Got the same issue, plugin not working on default permalink but in pretty permalink it works.

    I had the same problem with 3.01
    I think there is a conflict with WPML, as updating both caused the problem.
    Reverted to 2.5.72 to fix the issue.

    Plugin Author Eric Mann


    Incompatibilities with a premium plugin I do not own are not something I have time to fix. If this is a conflict with WPML, and downgrading works for you, then downgrade. Otherwise, please contact the support team at WPML where you are paying to support the plugin.

    But I don’t use WPML and have the same problem.:

    Using Standard Permalinks solves the problem! But of course I don’t want to use Standard Permalinks just because of one plugin.

    Hope there is a solution coming soon!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Error 404’ is closed to new replies.