WordPress.org

Support

error

  • I had Theme My Login working without problem on a multi-site install with just the redirection and themed profiles. I then added the plugin “User Role Editor” to create a new user role below subscriber. Everything still worked OK.

    I then enabled both the Custom User Links and Security. After saving settings, I lost the admin page for the sub-site and get the error

    Warning: Invalid argument supplied for foreach() in /home/content/31/7500231/html/vetpowersandbox/wp-includes/post.php on line 3588

    I still had access to network admin where I was able to de-active Theme My Login and now I can get access to sub-site admin. I would like to use your plugin. Obviously one of the new settings is causing the problem. I deleted the plugin and re-installed/activated and I get the same error message.

    http://wordpress.org/extend/plugins/theme-my-login/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jeff Farthing

    @jfarthing84

    Can you disable the other plugins, leaving TML active, and see if it persists?

    Hi Jeff,
    Prior to deactivating all plugins, I tried to setup the ThemeMyLogin on another site on the network – as soon as I activated the Custom User Links module, I got the same Warning as above.

    I then deactivated all plugins (network and site activated) and reinstalled ThemeMyLogin. Went back to the original site that had problem and site activated ThemeMyLogin. With no other plugins activated, my admin screen was replaced with the same warning as shown above.

    If the issue is a problem with custom user links – I’m ok without using this module, however, the settings are not deleted when deactivating and deleting the plugin so re-installing brings back the error. How can I do a complete uninstall/delete to start over fresh?

    Plugin Author Jeff Farthing

    @jfarthing84

    You will have to delete the option with the key of theme_my_login from the wp_options table.

    Hi Jeff,
    I’m not sure if I followed your directions properly. I deleted theme_my_login from wp_options and then re-installed the plugin but I still get the error message on the blog site (#4)when the plugin is activated. I had hoped that I would be able to completely start over with a clean slate and just not activate the custom_user_links module which seems to be the problem.

    Also, note that in addition to previously deactivating all of the plugins to trouble shoot the problem, I also changed theme to default wordpress and I still had problem.

    Plugin Author Jeff Farthing

    @jfarthing84

    With multisite, each “blog” has it’s own options table. You’ll probably need to delete it from wp4_options.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘error’ is closed to new replies.
Skip to toolbar