Support » Plugin: LocateAndFilter » Enable Openstreetmap HTTPS support

  • Resolved getiem

    (@getiem)


    Please add the HTTPS version of OpenStreetmap. If this plugin is now loaded on a page with HTTPS, you get a mixed content, because all tiles are requested over HTTP.

    Loading mixed (insecure) display content “http://c.tile.openstreetmap.org/7/69/41.png” on a secure page

    As https://c.tile.openstreetmap.org/7/69/41.png is available, you can just enable HTTPS really easy!

    It now prevents quick loading of the page.

    Thanks

    • This topic was modified 5 months, 1 week ago by getiem.
Viewing 8 replies - 1 through 8 (of 8 total)
  • I enabled it for myself on:
    locateandfilter / includes / class-locate-and-filter.php

    Change
    $overlays = array((object)array(“name” => ‘OpenStreetMap’, “url” => ‘http://{s}.tile.openstreetmap.org/{z}/{x}/{y}.png’,

    To
    $overlays = array((object)array(“name” => ‘OpenStreetMap’, “url” => ‘https://{s}.tile.openstreetmap.org/{z}/{x}/{y}.png’,

    Hi,

    I am having the same issue. Did you just changed the code in the core plugin file? Does it have any other permanent solution?

    For quickfix I just replaced code in plug-in core.

    There is however another file to change for the admin part of the plugin.

    I decided to remove the plugin from my website. It worked ok. But I had to generate a map for every category, which is a lot of work for my site. And setting the location for every post was slow (HTTP issue too) and generated some errors (see also my post about wrap around).
    For both issues I delivered a quick solution, but until now it is not fixed in the plugin as far as I know.
    Without map, my photoblog is now 99% pagespeed score and 90%yslow. With map this was decreasing drastically because of http too.

    • This reply was modified 1 month, 3 weeks ago by getiem.

    Thanks for the info. Hope the plugin developers will fix this important issue and release an update soon.

    Plugin Author dgamoni

    (@dgamoni)

    Hi guys
    I’ll fix this in the next few days

    Plugin Author dgamoni

    (@dgamoni)

    it’s fixed
    please update the plugin to version 1.3.572

    👍👍

    Really helpful. Thanks. 👍👍👍

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.