Support » Theme: Edin » Enable full width sections on front page/ footer

  • Resolved Katie

    (@greenpeadesign)


    Hi there,
    I can’t get the edin theme to go full width. There is white space on the left and right of the front page image, the front page widgets and footer widget area.
    I looked at previous threads that said to reset the background colours to default. On my screen I don’t see a default option in customiser.
    What have I done wrong?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Sarah Blackstock

    (@sarahblackstock)

    Automattic Happiness Engineer

    Hi! Do you mean you want the whole site to be full width? Or the posts/pages within the current post/page area to be full width (meaning no sidebar)?

    If you can clarify and share a link to your site, I’ll take a look! 🙂

    Katie

    (@greenpeadesign)

    Yes, I mean I want the site to be full width. The site is here: http://labelsperth.com/

    Sarah Blackstock

    (@sarahblackstock)

    Automattic Happiness Engineer

    Ah, okay. Edin’s Front Page usually is full width (like the demo here: https://edindemo.wordpress.com/), so looks like there’s something in your theme code changing that. I haven’t spotted what it is yet though.

    Since you’re using the Jetpack plugin, make sure the Custom CSS module is activated, then in Appearance > Edit CSS, add this:

    .site {
    	width: 100% !important;
    }

    Or this variation looks like it will work too:

    #page {
         width: 100%!important;
    }

    I tested it on the front page and it looked good, but be sure to check out other pages too to see how they adjust.

    Let me know how it goes! 🙂

    (I’ll be sure to let you know if I spot what’s doing it in the first place, so we can fix the original cause if possible.)

    Sarah Blackstock

    (@sarahblackstock)

    Automattic Happiness Engineer

    Are you using a Featured Image on the page set to Front Page?

    That’s the one that will display full width across the top on the Front Page template like in the demo, but it looks like yours could be set using a background image right now? Changing that may fix this, so wanted to mention it! 🙂

    Katie

    (@greenpeadesign)

    I’m using featured image on the page set to front page (not using background). I’ve dropped in the css and that fixed the site.

    Sarah Blackstock

    (@sarahblackstock)

    Automattic Happiness Engineer

    Great! 🙂

    Hi – I just tried to use your recommended CSS code on my site, but it doesn’t seem to be adjusting anything. It is still all narrow. Can you take a look @sarahblackstock my site is at wearebrainerd.org. thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Enable full width sections on front page/ footer’ is closed to new replies.