WordPress.org

Support

Support » How-To and Troubleshooting » Embedding Code

Embedding Code

  • I have looked around the forums without success on this issue. When I try to paste code into the HTML portion of the post page, iframe code completely disappears, object code gets stripped down, and other embed code either disappears or gets stripped down.

    I have looked for plugins, but can’t find anything that keeps the code in tact. I have disabled my plugins thinking that might be the issue. I have been downloading videos, uploading them, then inserting them with another plugin, but it is very time consuming and I am unable to embed google docs, polls, etc.

    Any help would be appreciated!!

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi

    @esmi

    Forum Moderator

    Try using the HTML tab – not the Visual tab.

    You can’t include PHP scripts in a WordPress post without a plugin…..

    esmi

    @esmi

    Forum Moderator

    Since when was iframe, embed and object markup PHP code?

    I did include the code in the HTML area of the post. I have done this a million times in my edublogs blog, but am not able to here.

    So….anyone know of a plugin that will allow me to do this???

    esmi

    @esmi

    Forum Moderator

    What’s the code you’re trying to insert?

    here is an example of youtube embed code:

    <object width=”425″ height=”344″><param name=”movie” value=”http://www.youtube.com/v/NN2I1pWXjXI&hl=en&fs=1&”></param><param name=”allowFullScreen” value=”true”></param><param name=”allowscriptaccess” value=”always”></param><embed src=”http://www.youtube.com/v/NN2I1pWXjXI&hl=en&fs=1&” type=”application/x-shockwave-flash” allowscriptaccess=”always” allowfullscreen=”true” width=”425″ height=”344″></embed></object>

    After publishing the post and/or saving a draft the code completely disappears.

    here is code from a google docs presentation:
    <iframe src=”http://docs.google.com/present/embed?id=d62xg4f_22g9d6gj7r” frameborder=”0″ width=”410″ height=”342″></iframe>

    After publishing the post and/or saving a draft the code completely disappears too.

    I ended up finding embed code online and tweaking it:
    <embed src=”http://www.youtube.com/v/NN2I1pWXjXI&hl=en&fs=1&”
    autostart=”false” />
    This gets stripped too…

    esmi

    @esmi

    Forum Moderator

    Did you switch back to the Visual tab at any point after adding this code?

    I did. I see the yellow box where the video would show. When I save the post, the box dissappears along with the code…

    try using tinymce advanced or execphp, although it doesn’t seem you need the latter as you are not inserting php code. Tinymce advanced has some options however that might be useful.

    thanks! I installed the tinymce advanced plugin and got the video embed icon I used to see on other blog sites. I used the button, got the code in the html area, the yellow box in visual, but when I saved it, the code was stripped again…

    I give up!

    I agree with janzalone… this didn’t used to happen. I’ve noticed that this has just started happening with 2.9.

    If you edit and re-save in visual editor you lose your HTML (whether a YouTube video or a flash audio file code).

    I have this same issue, but the admin of the site is able to embed video just fine. I have disabled the visual editor in my profile so that it doesn’t even show up in the blog post and tried to embed the video code this way and it still disappears.

    Any fresh ideas?

    Anyone figured it out yet? If not – the solution is installing “Vipers Video Quicktags”

    you won’t be able to edit existing posts, but when you add new posts with a video – it’ll work fine. Just click the tab and then insert the URL, and you can customize the dimensions.

    I hope this helps!!

    I am trying to put two custom fields for uploading audio as well as thumbnail but the files are not getting upload on the specified location.
    And I don’t want to use any plug-in. This is a type of custom coding.

    Thanks In Advance

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Embedding Code’ is closed to new replies.