Support » Plugin: Directorist - Business Directory Plugin » Editor Capabilities

  • Resolved rmgl

    (@rmgl)



    Hello,
    I would like to a user on my site who has the editor role, the option to edit the listings on the directorist plugin. But it seems that the required capability to access the plugin is edit_at_biz_dirs which only works for me the admin. How can I change this?
    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author aazztech

    (@aazztech)

    Hi,
    Thank you very much for pointing out this issue. We have checked the issue and fixed it. All users do have edit_at_biz_dirs caps so that any user can edit at least his own listing. By the way, we have found the problem that caused the issue eg. preventing editor edit others listing. We have fixed it already and we will provide an update after tweaking another small issue tomorrow. Please download the updated version of the directorist as soon as you get the update notification on your dashboard and your problem will be fixed.

    Khinson6

    (@khinson6)

    Is there a reason why all text typed into the editor window for adding a listing is run together like one huge paragraph?

    What do I need to do in order to have the Add New Listing page Editor give me Paragraphs for better formatting? Is there a setting I can change, do I need to edit a file or what, need this feature badly.

    Plugin Author aazztech

    (@aazztech)

    Hi khinson6,
    Could you please open a separate support ticket for the unrelated topic next time? Your query is not related to Editor Capability. People with the same problem may find the solution if you open a separate ticket. You might have created a ticket with the title “Content in listing details page does not format nicely” or “Content in the listing page displays a huge paragraph” etc. We are saying this only to help everyone find a solution to the similar problem. Thank you for your understanding.

    By the way, here is the solution for now. We will add this in the next release though.

    1. Open the file single-at_biz_dir.php from the following location.
    plugins/directorist/templates/single-at_biz_dir.php

    2. Please replace the lines 141 and 142 in single-at_biz_dir.php with the following 2 lines of content.
    $cont = $wp_embed->autoembed($wp_embed->run_shortcode(wp_kses_post($post->post_content)));
    echo wpautop(do_shortcode($cont));

    3. Then save the file. and reload your website and remove the browser cache if you do not see the result.

    It should fix your problem.

    Thanks for the fix, will try it now.

    Just in case others may need this info, I’m going to post it as a new support ticket with the same above request, so you can repost the solution.

    Thank You

    Plugin Author aazztech

    (@aazztech)

    No problem. 🙂
    Thanks, mate.

    Plugin Author aazztech

    (@aazztech)

    No problem. 🙂
    Thanks, mate.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.