Support » Plugin: Elementor Page Builder » Edit mode with https

  • when I try to edit my page using Elementor editor .. I lose https because I have eneabled enfore external https request and my hosting provider told me that Elementor still use http resources during launching the editor..

    so, could you fix those http to https ?

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Are you using Siteground? If so, there is a simple solution.

    Please log in to your Siteground.com account, go to Site Tools and disable HTTPS Enforce. Then clear the Siteground server cache and clear your browser cache.

    You can then enable HTTPS Enforce via Siteground’s SG Optimizer plugin. Using that feature via the plugin works fine, but using the feature from siteground.com causes this issue. So disable it on siteground.com and enable it via the SG Optimizer plugin, and it should be fine.

    Thanks for your solution, yes I do use SG. But I stil recomment that Elementor team shoud fix the problem from their side if possible..

    Thanks again

    I’m pretty sure this is a Siteground issue.

    Their tool rewrites all http to https which breaks XMLNS namespacing (a feature unrelated to https) – because they change a standardized “name” that should not ever be changed, thinking it is a “url” when it isn’t, the site breaks. Just keep that feature turned off and you’ll be fine.

    See https://github.com/elementor/elementor/issues/7788

    I’ve tried explaining but it seems like no one at SG is listening.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Edit mode with https’ is closed to new replies.