Support » Fixing WordPress » Edit Image Button is missing

  • didi.carolina


    I´ve some issues with the edit image button on my wordpress.
    I was post some image and the button is edit image is missing, i can´t select crop or other functions because the feature doesn´t work anymore.
    But it started in this week! A week ago it´s working fine =/

    I changed the theme for the wordpress theme, i deactivated all my plugins (google analytics, WP-reCAPTCHA, Photo Galleria, Formidable) and all my widgets (wordpress widgets like archive, post recents, etc), and nothing works!

    I have a wordpress installed in my local machine, and i tested the same theme and works fine!

    I don´t know what is going on because, it worked fine until last week.

    I have the work-a-hollic theme from graphic paper press installed with my customization and design, but i think there´s something wrong with the wordpress not in the theme, because, everything is working fine in my local installation.

    Please help me! I need to crop my thumbs, because the theme is based on the “feature image” – it´s a portfolio´s site.

    And sorry for my bad english =)


Viewing 14 replies - 1 through 14 (of 14 total)
  • didi.carolina


    up! please help me =)



    Forum Moderator

    Have you tried:

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    – increasing the available memory?

    – reviewing



    I will try it and soon i will come back to report the results!

    Thank you so much!



    I change everything that you suggested and nothing!
    I really don´t know what is going on!

    The folder uploads now don´t upload thumbnails sizes, and the size in the image upload it´s disable.

    I try to remove the theme and upload it later, i removed all plugins, and update the wp_admin and wp_include folder, i increased the php memory in php.ini

    And nothing works! Please, any suggestions?
    I have my portfolio read, but i need to update more works and i can´t to this with this problem =(

    If somebody have more suggestion let me know!
    Tks =)



    Forum Moderator

    Have you tried using the TwentyTen theme?



    Yes! i have it! and nothings works! =(
    I´m almost thinking to restart the wordpress!

    My wordpress was working fine until last couple weeks =(
    In my local server the same instalation and the same theme is working absolute fine.

    last minute ago, i changed my .htaccess and the error is the same.

    Everything in edit image won´t work… the button is missing, the thumbnails aren´t generated, it don´t know what to do anymore.

    Any others ideas?


    This it drives me crazy!

    First of all, i reinstalled all my wordpress, and nothing worked.

    I deleted my wp-adim, and wp-includes, and all files in the root directory.
    I copy my new files (wp-admin, wp-includes, and wp-files in the root directory)

    I deleted all plugins and widgets.

    I started all new fresh wordpress.

    My working theme (i have a localserver in my machine, and the edit fuction is working here) is now active, and when i created i new post, and inserted a new image… surprise: MY EDIT IMAGE BUTTON IS STILL MISSING!


    i have a wordpress 3.0 working without plugins in my server, and it coud be any database problem?
    Or could it be any problem in my server host?

    This edit button was working absoluted fine 3 weeks ago!

    Please, i need help, my theme is based on thumbnails with crop (because it´s a portfolio base)

    Please please please, i really don´t know what to do anymore.
    I need to update my portfolio, and it is not working with crop image for photoshop beacause the image posted is the same thumb and the feature image.

    i don´t have anymore ideas. I~m 3 weeks searching for the solution. I changed my php.ini, my htacess, all folders… i´m almost erasing everything and shutting down my website =(

    Any help will be appreciate!

    (sorry for my really bad english)


    Install php-gd

    I’m having the same issue on only one blog. Have reinstalled wp, deactivated all plugins and reset to default theme to no avail.

    Hi there,

    I was looking for answer for this problem too and then applied this trick which worked for me. In wp-config.php add this string:

    define('CONCATENATE_SCRIPTS', false);

    This will prevent WP to load all scripts at once, will surely slow down your admin experience but guarantee that each one of them doesn’t get overlapped in the loading process. Hope it will help.

    Don’t know if this solved the issue, but for me it helped realizing that WordPress expects a JPEG file type, not a JPG. Hence the button never showed up until I tested it with a png image file which worked fine.

    I am running another blog on the same server where the edit media button showed up when I clicked on a JPEG file.

    ==> File type: image/jpeg

    The problem arose while using an external editor on Windows ( which apparently has some open issues and changes the file type from jpeg to jpg during upload. I take it that “file type: image/jpg” isn’t defined for the call of the button, hence it doesn’t show up.

    I have this problem now, tried jpeg, jpg & png and not showing up. I’ve run into this problem before and it was due to double line spacing in my functions.php file or files that are included in functions.php The weird thing now is that it’s working fine on my localhost but not the live server. I run into this problem more than any other on WP!

    I can confirm what kikuyumoja wrote. Using Blogdesk changes the mime-type to “image/jpg”, and for some reason WordPress’s code requires “image/jpeg” only.

    This bit of SQL will fix the problem for existing images:

    UPDATE wp_posts SET post_mime_type = “image/jpeg” WHERE post_mime_type = “image/jpg”;

    It’s probably possible to create a plugin (or add a line to your theme’s functions.php) that calls this SQL each time an image is added to the DB…

    The better alternative would be to get the core WP code updated to display the edit image button for “image/jpg” files.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Edit Image Button is missing’ is closed to new replies.