Support » Plugin: Ecwid Ecommerce Shopping Cart » Ecwid Plugin Update: Error Message

  • Resolved Breezy92

    (@breezy92)


    Just updated my Ecwid shopping cart plug in and got this error message across the front page:

    Strict Standards: Non-static method Ecwid_Store_Page::get_store_pages_array() should not be called statically in /home2/nori/public_html/earthenurban.com/wp-content/plugins/ecwid-shopping-cart/includes/class-ecwid-store-page.php on line 129

    Strict Standards: Non-static method Ecwid_Store_Page::get_store_pages_array() should not be called statically in /home2/nori/public_html/earthenurban.com/wp-content/plugins/ecwid-shopping-cart/includes/class-ecwid-store-page.php on line 129
    Strict Standards: Non-static method Ecwid_Store_Page::get_store_pages_array() should not be called statically in /home2/nori/public_html/earthenurban.com/wp-content/plugins/ecwid-shopping-cart/includes/class-ecwid-store-page.php on line 129
    class=”home blog logged-in admin-bar no-customize-support”>

    PLease Help!
    thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Ecwid Customer Care

    (@ecwid_team)

    Hi!

    Ecwid Customer Care Team here. Thank you for the message!

    We are really sorry to hear that you faced this! The warnings you see are Strict Standard notices and they are usually hidden. We are already working on this issue and will do our best to fix it on our side. Now in order to get rid of these messages we would recommend you to contact your hosting support and ask them to change php settings. You can write them something like “How to edit php.ini configuration to hide “Strict Standard” notices on the site?” Just in case, here is the instruction: http://www.inmotionhosting.com/support/website/php/strict-standards-fix

    As we can see you have already contacted us on that matter. Our agent sent a reply to your email address as well. Please, check your mailbox.

    If you have any further questions, please feel free to contact Ecwid Support. We will be happy to answer and help.

    Plugin Author Ecwid

    (@ecwid)

    We fixed the issue. Please update your plugin to the latest version — the “Strict standards” notices should not appear anymore.

    Thanks,

    THANKS SO VERY MUCH!!! ITS PERFECT NOW!! REALLY APPRECIATE IT !

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Ecwid Plugin Update: Error Message’ is closed to new replies.