Support » Plugin: Fast Velocity Minify » Dynamic CSS

  • Resolved Stu

    (@dblinks)


    Using the Avada (themeforest) theme I have great success with your plugin and in conjunction with the “Simple Cache” using page and memcached on that plugin.

    In Avada options you can dynamically use the database and CSS Compiler. I have turned the CSS Compiler off as it was not playing well (A separate file will be created for each of your pages & posts inside of the uploads/ folder).

    The dynamic CSS for the database cache is left “On” and works as expected. Very consistent <2 second page loads and good pagespeed overall excellent.

    I have another client with the “3Clicks” theme from Themeforest. Not as popular as Avada but a very stable product. It also creates dynamic css in /wp-content/themes/3clicks/css/g1-dynamic-style.php?respondjs=no&ver=3.9.3

    When I installed your plugin and turned off the theme dynamic css, deleted the css (dynamic) upload file, cleared server, local and Cloudflare caches & restart php5-fpm the theme is completely broken. I find it close to impossible to identify which css and js files need to be ignored. Is there a procedure written on how to selectively choose which files may be problematic?

    Great plugin I’m really liking it.

    stu

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Raul Peixoto

    (@alignak)

    Hi,

    This sounds a bit tricky, because how the plugin works is by determining the relative path and opening it… a dynamically generated php / css file is not going to work.

    I’ve been considering some changes on the plugin to bypass this kind of thing, but not ready yet.

    For now, what you can do is to go to the plugin settings and disable js and css processing and check if the site works properly (this disabled the plugin, basically).

    If it does, enable the js processing first and test again.
    If it still works, enable the css processing and take a look at the minification log on the status page.

    Copy paste all those css urls to the ignore list and save. Does it work?
    Should work, since you’re excluding them all… unless something is breaking due to the dynamic css file. If that’s the case, let me know.

    If not, try to remove one by one from the ignore list, until you find the culprit.

    Plugin Author Raul Peixoto

    (@alignak)

    good news, I’m working on a solution for this.

    Plugin Author Raul Peixoto

    (@alignak)

    This should work on version 1.3.5, if the stylesheet or js url includes “.php?” (dynamic) it should be ignored from now on.

    Let me know if it works for you, thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Dynamic CSS’ is closed to new replies.