Support » Plugin: Event Calendar & Ticketing » duration

  • Resolved onirgoc


    Hello !

    No news about direct support…maybe my mails are in spam folders ? so I post this here :

    whatever ! I would like to help because this plugin is the only one who have understand real needs of user (connected to woocommerce, sell tickets, gift option…etc)

    so has the calendar shortcode is not working for me even after testing few different basic install, english, french wp, with and without woocommerce, I decide to have a look in the code…mmmm….I am not a devlopper but :

    looks like line 621 of event-calendar-ticketing.php there is this as line 153 in events-widgets.php :

    $duration = get_post_meta( $p->ID, '_ignitewoo_event_duration', true );

    but the problem to me is that _ignitewoo_event_duration has no value !
    I checked in phpmyadmin and find start value and end but no “duration”

    so : widget is displaying same starting date/hour and ending because at line 166 there is :

    echo '<br/>' . date( $settings['date_format'] . ' ' . $settings['time_format'] , strtotime( $s ) + $duration );

    with empty duration !

    I don’t have any idea how you calculate duration but I am almost sure that the piece of code needed here is part of the “pro version” and you may have forgot to test your plug without it…I know time is missing !

    Hope it will help !

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author IgniteWoo Team


    How do you have your event configured exactly? Let us know and we’ll test the same config on our dev server.

    Also keep in mind we’re in the USA, so consider the time difference and also note that we may or may not work weekends, depends on what we have going on in terms of personal life.

    yes I know there is only 7 hours between us 😉

    event is configure almost by default means I change only :

    Expired Events : Do nothing
    Default Event Date Format : 7 Dec 2014
    Default Event Time Format : 23:00

    and that’s it !

    wordpress is setup with only one change but I already test others:

    Permalink Settings :

    I am testing on easyphp and woocommerce is working fine but is it a “path” question in your code ?

    I mean normally a site address should be something like ….with easyphp the adress is …let me know?


    to find out what’s going on I just setup a online test site for you with the very basic install : only wp last version and your plugin…same problem… so if you want I can send you by private mail the login/password to make you able to check it.

    Let me know.

    mmm…here it’s 10am…3am for you…have a good night ! 😉

    Plugin Author IgniteWoo Team


    Yes, send it over using the contact form on our site at

    sent !

    Plugin Author IgniteWoo Team


    Fixed. Thanks for the bug report!

    You are welcome! See you on the next one ! 😉

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘duration’ is closed to new replies.