Support » Localhost Installs » Double domain

Viewing 6 replies - 1 through 6 (of 6 total)
  • Are your WordPress files installed in the public root?
    I.e. In what directory are the directories wp-include, wp-content and wp-admin located?

    Can you please share the content of your file .htaccess that should be in the same directory (probably public root). (Before posting, just check quickly that the file doesn’t seem to contain any sensitive stuff.)

    EditAdd: You’re going to need an FTP client for this, for instance FileZilla. Details on how to connect should be available somewhere from your hosting provider.

    Hi Tor-Bjorn,

    Thanks for your reply!

    The htaccess is the root directory together with the Index and website file, the wp files are within the website file.

    htacces:

    
    ####SUBDOMAINS_HEADER####
    RewriteEngine on
    #RULE:,kandidatennet.nl,/kandidatennet.nl/
    #RULE:www,kandidatennet.nl,/kandidatennet.nl/
    RewriteCond %{HTTP_HOST}    ^kandidatennet.nl$
    RewriteCond %{REQUEST_URI}  !^/kandidatennet.nl//
    RewriteRule (.*)    		/kandidatennet.nl//$1 [last]
    RewriteCond %{HTTP_HOST}    ^www.kandidatennet.nl$
    RewriteCond %{REQUEST_URI}  !^/kandidatennet.nl//
    RewriteRule (.*)    		/kandidatennet.nl//$1 [last]
    ####SUBDOMAINS_TAILER####
    
    ####CUSTOM_HEADER####
    #NL: Place your custom rules here
    #EN: Plaats je eigen regels hier
    php_value memory_limit 64M
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    ####CUSTOM_TAILER####
    
    ####ERROR_HEADER####
    ####ERROR_TAILER####
    

    Greetz,
    Sjoerd

    Please edit the reply you just sent, select the code sample and click on the code button. (In this particular case nothing broke, since you don’t have any html here, but it will still look nicer. (You’ve got another 55 minutes to do this edit).

    Let’s try this:

    Go back to General settings and delete that “double-domain” entry under “Website address”.

    Next change .htaccess (yes, the file name starts with a dot) so that it only contains:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    In any case, you’ve got a backup of this file here, above.

    Good luck.

    Hi,

    It did not work, it caused a hosting error. I set the website address back to single name and changed all the code from the .htacces file except for the remaining code. I tried again to completely remove the website address in settings, but it came back soon as I saved settings.

    What we found before was that the wordpress address contained the same double domain name. Since we found the databse connection was good, it was obvious the double name in wordpress address was unnessecery. Therefore we had brought it back to single domain name. And it gave no errors, except for the website address.

    Anyway, the hosting provider says it is not coming from their side or the database. I will try something else and see if the bug comes from a plugin installation or something.

    Many thanks!

    By the way, we also found that for the pages when manually delete the second domain name form the url, the page works fine as http://domain.xx/page-title/

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.