WordPress.org

Support

Support » Plugins and Hacks » [Resolved] doesn't work with

[Resolved] doesn't work with

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author flashpixx

    @flashpixx

    Please read the requirements, you need PHP 5.3 at least

    You’re right. I have PHP 5.2. My bad.

    Hello, recently i modified this plugin to be php 5.2 compatible. If any of you are interested i can provide this modified version.

    Plugin Author flashpixx

    @flashpixx

    Do you remove the PHP Namespaces?
    I’m using the NS, because I can create seperated structures on all my plugins and PHP 5.2 is a very old system, so an upgrade should be better choice because security reasons.

    I will migrate my plugins to GitHub and use GitSVN to update the plugindata on WP, so this can be a fork on the plugin source. I don’t want create a downgrade of the plugin source, except it is needed

    Thanks

    As you probably know, there is no support for namespaces and anonymous function on php 5.2 so it was necessary to removed them (an replace them with something else) in order to run the plugin on that php version.
    Also there are a lot of hosting websites which offer only php 5.2 or even older versions.
    In my case i developed the website on php 5.3 and after i uploaded on hosting website i saw that they had only php 5.2.17 so the solution was to adapt your plugin not to remake the entire website.

    Plugin Author flashpixx

    @flashpixx

    I know only that PHP 5.2 does not have any namespaces, but the problem with anonymous function are unknown for me.

    I’m thinking about a port to GitHub, because in your case you can fork the plugin sources. Do you think, this can be helpful for you? In this case I can migrate the plugin sources to GitHub.

    pixecs, it would be great if you share modified version with me. My e-mail: cutterrus@gmail.com. Thanks.

    I’m thinking about a port to GitHub, because in your case you can fork the plugin sources. Do you think, this can be helpful for you? In this case I can migrate the plugin sources to GitHub.

    – i already solved my php 5.2 issues but i think somebody else may find usefull that your plugin will be available for php 5.2

    Kind Regards,
    Ciprian

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] doesn't work with’ is closed to new replies.