Support » Plugin: KC Settings » Doesn't work select image when edit term

  • fillantoxa

    (@fillantoxa)


    Doesn’t work select image when edit term (on term.php page like …/wp-admin/term.php?taxonomy=some-tax).

    There no active ks settings on this page.

    Found solution for this problem like add next line (after line 9 – kcSettings::add_page( ‘edit-tags.php’ );) to file plugins/kc-settings/kc-settings-inc/term.php :

    kcSettings::add_page( ‘term.php’ );

    hope help someone in future 🙂

    https://wordpress.org/plugins/kc-settings/

Viewing 2 replies - 1 through 2 (of 2 total)
  • @fillantoxa I have the same problem with you. The image-selecting page is not opened inside the selecting field but jumps to a new page instead so that there is no data sent back. Did you fix it?

    I’m afraid that this plugin has stopped maintenance.

    Hi, in my case solution was:

    add next line (after line 9 – kcSettings::add_page( ‘edit-tags.php’ );) to file plugins/kc-settings/kc-settings-inc/term.php :

    kcSettings::add_page( ‘term.php’ );

    So it look like

    class kcSettings_term {
    	protected static $settings;
    
    	public static function init() {
    		self::$settings = kcSettings::get_data( 'settings', 'term' );
    		kcSettings::add_page( 'edit-tags.php' );
    		kcSettings::add_page( 'term.php' );
    • This reply was modified 1 year, 8 months ago by  fillantoxa.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Doesn't work select image when edit term’ is closed to new replies.