Support » Plugin: Secure Blocks for Gutenberg » Doesn’t work

  • Resolved slimmilkduds

    (@slimmilkduds)


    Hi, this is a really neat idea for a block. Unfortunately it doesn’t work. I’ve tried with both custom roles and with setting the role to administrator and I can still see all secure blocks whatever user role I use to login. Using version 3.6.2 of Gutenberg

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Matt Watson

    (@mwtsn)

    Hi @slimmilkduds, there is a good chance we were not using compatible versions of the Gutenberg code. Now WordPress 5.0 is released and we have a stable codebase can you give it another shot and let me know if you are still having issues?

    Not working here, either.

    Using v1.4.1 of the plugin, and WordPress v5.0.1.

    I was previously using ‘restrict-content-by-role’, but that’s currently marked as “closed on August 10, 2018 and is no longer available for download. Reason: Author Request“.

    There’s over 2000 active installs, including myself, so I found it’s complete withdrawal a bit of a surprise. Myself, I was using it as a key piece of a client’s site implementation. I found out about that today when I started getting back up to speed on the project, and installed WP from scratch, and noticed my wp-cli install script had trouble pulling it down from the plugin repository…

    An unpleasant surprise, to be sure, but luckily I still have the copy on our production and staging servers. (And there’s the git repo, of course.)

    That said, I’m looking into migrating over to the Gutenberg editor, but I just found Secure Blocks non-functional a moment ago.

    So I’m kind of stuck between options at the moment. šŸ˜‰

    Was there any reason for ‘restrict-content-by-role’ to be taken down? Incompatibility with 5.x, perhaps?

    Much thanks, and appreciation for the work being done. šŸ‘

    Plugin Author Matt Watson

    (@mwtsn)

    Hi @fortyseven,

    You can still download Restrict Content by Role here: https://github.com/mattwatsoncodes/restrict-content-by-role however I removed it because it had not been updated for a couple of years there are much better alternatives out there.

    It was in desperate need of a full re-write that I have just not had time to do, but I will be expanding this plugin to eventually over-take it.

    What issues were you having with the plugin? Any errors?

    This is the one I recommend to replace restrict content by role: https://en-gb.wordpress.org/plugins/restrict-content/ alternatively you can download the version from GitHub.

    What issues were you having with the plugin? Any errors?

    I haven’t observed any obvious errors. The plugin is installed, and activated. But in the Gutenberg block dropdown, there’s nothing present.

    For what it’s worth, when comparing the blocks UI with the YouTube introduction on the homepage, it looks a bit different: https://i.imgur.com/rPHruHq.png (Though I’m guessing that video was from a beta?)

    And just to be thorough, typing “sec” to pull up the block, brings up “No blocks found”. ;(

    I checked the logs to see if anything weird was going on, but no dice there, either.

    I also tested this on a WP Engine hosted site, and one I have standing up in a Docker container in a VM I use for development. (Same WP/plugin version, though.)

    And finally, I reverted to the stock theme, and disabled all the other plugins in case there was some kind of weird interference from them — still no luck.

    (And I do find myself double-checking that it’s activated, like, all the time. ;D)

    A curious mystery!

    Thank you for the update and suggested alternative! Looking forward to Secure Blocks playing ball with me at some point, but in the meantime I’ll check out the alternative since I’m on a bit of a ticking clock.

    Happy to try out anything that might help you debug this. I’ll try and look a bit deeper at it in my off hours, myself.

    UPDATE: So this is interesting. I took one of my personal WP sites and installed the plugin over there. It shows up. -> https://i.imgur.com/ELQuQwN.png

    Innnnnnnnteresting.

    I’ll keep poking at it and see if I can find out where the installs diverge, because they’re both setup pretty similar…

    Plugin Author Matt Watson

    (@mwtsn)

    I believe it’s down to the order of the enqueueing of the assets. I’ll take a look tonight, and see if I can fix it.

    Plugin Author Matt Watson

    (@mwtsn)

    Hi @fortyseven, @slimmilkduds I have updated the plugin and it should now be working for you. Iā€™d appreciate if you could give it another shot.

    fortyseven

    (@fortyseven)

    It does indeed work now! šŸ˜€

    Much appreciated!

    https://i.imgur.com/fju6plV.png

    Plugin Author Matt Watson

    (@mwtsn)

    No worries @fortyseven, and better still I’ve turned on alerts for plugin support, so my response time should be a little bit quicker in future!

    (Sorry)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Doesn’t work’ is closed to new replies.