Support » Plugin: Lazy Loader » does not work well with tiled galleries

  • Resolved LoreGI13

    (@loregi13)



    Hi
    I had a bad experience: this lazy load does not work with column tiled galleries:
    the gallery displays confusing and superimposing rows and images (I’m using Photo Gallery by Supsystic)

    • This topic was modified 1 year, 8 months ago by  LoreGI13.
Viewing 15 replies - 1 through 15 (of 15 total)
  • I think I am getting a similar problem on pages where I uses Isotope. It seems as if Isotope is unable to get the image heights and therefore fails to display the gallery correctly. Is there a way to disable the effects of this plugin just for certain parts of the site?

    I have added the plugin “plugin organizer”

    https://en-gb.wordpress.org/plugins/plugin-organizer/

    It can be used to disable the lazyload plugin where it has a negative effect. Not ideal, as it disables lazyload on the whole page not just the Isotope gallery, but better than nothing.

    ‘Plugin organizer’ is no longer fixing the problem 🙁

    There is a definite clash between ‘Lazy loading responsive images’ and Isotope type layouts.

    In Chrome, images from Isotope are all stacked on top of one another if ‘Lazy loading responsive images’ is enabled. As fas I can tell it is only an issue in Chrome. Seems fine in Firefox.

    As all my Isotope images happen to be the same aspect ratio I can fix the problem with js by specifying img height as a proportion of width. However, if the gallery had lots of different sized images I can’t see what the solution would be. Maybe giving class names to images based on their aspect ratios?

    I think there needs to be a way to disable the lazy load functions for specific sets of images.

    • This reply was modified 1 year, 7 months ago by  julian_wave.
    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Hey!

    Yes, masonry grid layouts and lazy loading solutions are not good friends by default… The problem is that the calculation for positioning the images is wrong if the images are not loaded when the grid script runs, and the script cannot know the dimensions of the image which will be lazy-loaded into that place later.

    A solution for that is adding the image dimensions as an inline style to the image element https://florianbrinkmann.com/en/3405/lazy-loading-images-in-a-masonry-grid/

    I do not this can be handled for all cases by the lazy load plugin…

    That is what I suspected. I think it is important to find a reliable way to disable lazyload for this kind of situation – but I haven’t found one yet! Would it be possible to tell lazyload to ignore images with a specific classname, for example?

    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Yes, I will try to add an option for a class name with the next release!

    That would be great, thanks!

    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Hey!

    I uploaded 3.1.0 with a customizer option to add class names of images which should not be lazy loaded. Would you give it a try and check if that works for you?

    Thanks!

    Hi Florian,

    I’m sure I must be missing something simple, but where can I find the customizer option?

    Best wishes,

    Dave

    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Hi Dave,

    should be available under AppearanceCustomizeLazy loading options 🙂

    Cheers,
    Florian

    Hi Florian,

    I can not see lazy loading options in Appearance > Customize.

    See image screenshot

    Julian

    ps – is there a quick and dirty short term solution, my portfolio page is not looking good in Chrome!

    • This reply was modified 1 year, 4 months ago by  julian_wave.
    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Hi Julian,

    that is weird… This is how it looks on my site:

    Are you sure you have a plugin version newer or equal 3.1.0 installed? If so, could you try to check for conflicts with other installed plugins or your theme (via switching to a default theme and deactivating other plugins)?

    Florian

    And weirder…

    I had the latest version of the plugin, but I pressed “update” anyway, and then everything worked. Maybe page cacheing was to blame? Anyway, it all seems to be working now, and my folio looks fine again.

    Thanks very much for the quick response.

    Julian

    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    Yes, sounds like an odd caching problem… ¯\_(ツ)_/¯

    But nice to hear that it works now! 🙂

    Cheers,
    Florian

    Plugin Author Florian Brinkmann

    (@florianbrinkmann)

    @all: I will set this topic to »resolve« for the moment. Feel free to post a new response if you have ongoing problems with that 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘does not work well with tiled galleries’ is closed to new replies.