WordPress.org

Support

Support » Themes and Templates » displaying blog in summary with responsive theme

displaying blog in summary with responsive theme

  • souleye

    @souleye

    I’m working on a project using responsive theme. it’s an awesome theme and very flexible but I’m having issues with the blog display. I’m trying to display blogs in summary view with the ‘read more’ that users can click on to continue reading. I select the ‘blog summary’ template but still blog posts are showing full content. I go to settings and I select summary, but it’s still showing full content. this is puzzling me. I’m not a hardcore coder but I would think if you have a template that says ‘blog summary’, if you activate it, it should be displaying blog summary not full content. any assistance with this issue will be highly appreciated. thanks.
    souleye

Viewing 15 replies - 1 through 15 (of 23 total)
  • Emil Uzelac

    @emiluzelac

    Hi,

    What’s the link where this is located?

    Thanks,
    Emil

    souleye

    @souleye

    http://xhibitswebdesign.com/heather/?page_id=23
    it’s a test site. if you need login info so you may take a look at it please let me know. thank you.
    souleye

    Emil Uzelac

    @emiluzelac

    Hi,

    You’re not using Blog or Blog Summary Template here.

    Go to your WordPress Dashboard, click on Pages and add new Page and call it e.g. Blog. On your right you should have “Page Atributes”, locate Templates and switch to any of two available Blog Templates.

    Thanks,
    Emil

    souleye

    @souleye

    this is what I was noticing. when I created the new page and assigned it to ‘blog summary’ it worked. but when I added the posts: the original one and the test post filled with lorem, it’s not working anymore. that caused me a lot of head scratching. any assistance in this matter will indeed be much welcome. thanks.

    Emil Uzelac

    @emiluzelac

    It works now 🙂

    Emil

    souleye

    @souleye

    we’re not looking at the same page. now I’m beginning to see that it works when you create the empty page but when you make it the default page for blogs in the reading settings, it stops working. check this url to see what I’m talking about:
    http://xhibitswebdesign.com/heather/?page_id=118

    Emil Uzelac

    @emiluzelac

    Hi,

    Pages don’t have the ability to have “Read More” only posts do. I am referring to what comes as default by WordPress itself.

    However I can also see some customizations to the Theme directly, any time when we do them, they should always be in Child Theme form.

    We already established that Blog Templates work:
    http://themeid.com/demo/responsive/page-templates/blog/ for full posts
    and http://themeid.com/demo/responsive/page-templates/blog-summary/ for summaries.

    Now once we publish the posts and if we don’t use the Blog Templates they would display as summaries such as: http://themeid.com/demo/responsive/category/uncategorized/ however there’s also index.php which isn’t using summaries and you can change that if you wish:

    From:

    <?php the_content(__('Read more ›', 'responsive')); ?>

    To:

    <?php the_excerpt(); ?>

    Emil

    souleye

    @souleye

    thank you emil. I had thought of that, though I wasn’t sure which file I should modify. then I thought it was a surgical operation hoping there was a less drastic operation. all I need is to get the blog posts to display summaries. not full content. you’ve been very helpful and your theme rocks. I will contact you later to see how much you would charge if I wanted a theme based on a photoshop design. happy thanksgiving!

    Emil Uzelac

    @emiluzelac

    Happy Thanksgiving to you too 🙂

    I sent you an e-mail already, but if you have something else and when my time permits most definitely 🙂

    Thanks,
    Emil

    souleye

    @souleye

    emil

    hope that you had a nice holiday. your theme is wonderful and I finished and delivered the project but there’s still an aspect bedeviling me. I know I can always summarize content manually but there’s a more elegant way. I tried everything, it didn’t work.
    1. I used the blog summary template.
    2. I checked the index.php but couldn’t find any reference to <?php the_content(__(‘Read more ›’, ‘responsive’)); ?>
    3. I checked page.php and found that line, which I replaced with <?php the_excerpt(); ?>
    4. I checked blog-excerpt.php and it does call <?php the_excerpt(); ?> function.
    I wasn’t successful in any of those attempts.
    when I check your demo pages, everything works like a charm. I know you’re not a magician. you’re programmer.
    any assistance will be appreciated. thanks.

    Emil Uzelac

    @emiluzelac

    Hi,

    Can you please show me the specific link where this is happening?

    Emil

    souleye

    @souleye

    http://xhibitswebdesign.com/heather/?page_id=118
    this is the test page. not the live page.

    Emil Uzelac

    @emiluzelac

    Ah yes, I remember now, you showed me this already 🙂 Is this a Template or a page? The reason why I asked is because there’s no body classes in your Theme any more, there should be one by default.

    Emil

    souleye

    @souleye

    correct me if I’m wrong. I create a blank page and you call it blog. I select blog excerpt as the template for that page. in settings, you assign it to display latest post. then I go and write a normal blog which should be showing up on the blog page. I have similar setup with other wordpress sites. some of them show summary, if that’s what you select in settings. I have had instances the settings didn’t work and I changed it in the php files. why this is not working, I have no idea.

    Emil Uzelac

    @emiluzelac

    Absolutely, blank page with Blog or Blog Excerpt Page Template like this and after some post are published we’ll have Blog post as on my demo.

    In your Reading Settings, we have two options to choose a static Front page or your latest posts, now I can see that you already chosen a different static page and that’s all right, however can you check and see what’s under the Posts page, just under the “Front page” and make sure that no post is selected, meaning leave on – Select –

    Thanks,
    Emil

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘displaying blog in summary with responsive theme’ is closed to new replies.
Skip to toolbar