Support » Plugin: Simple Calendar - Google Calendar Plugin » Disabled Arrows?

  • I’m having an issue where my arrows switch to disabled mode ever couple clicks. I am using a Beaver Builder Module which may be causing the conflict. I too have tried to override the CSS, but the button function is still disabled. Any help would be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • i had the same problem: you have to go to /wp-content/plugins/google-calendar-events/assets/css/default-calendar-list.min.css and change color for this class
    “.simcal-default-calendar-light .simcal-nav-button:disabled”.

    I’m having the same issue. It’s not a color thing, the buttons are just disabled. I can see them, but nothing happens when clicked.


    So here’s what I’ve figured out. The calendar will only allow you navigate to months that have events. So even though you start the calendar “Today” if you don’t have events until two months later, once you navigate there, you can not return to “Today” unless you refresh the page.

    Yes, you can override the color of the disabled class, but that does not allow you to navigate.

    I don’t believe this is a great user experience, so I’m wondering if I need to add some kind of explanation for why the arrows disappear. Has anyone else done something like this? It’s a bummer that we would even need to do this.

    I’m really hoping this major issue gets resolved as well. There should either be the option to enable the buttons if there are no events, or just make it so they are always enabled. Always.

    Seems like it would be a pretty easy Javascript fix, right? Just find the code that disabled the arrow if there are no future events, and then delete it.



    I need help here, too. I have the same problem. Looking into the source-code, I see, that there is no link added to the arrows. And there ARE Events in the next month, so that it cannot be the cause.
    I figured out, that the plugin works fine with other themes than mine. I made a new one, so I think I have to add a script or anything else to make it work.
    In my source-code I see that in other themes there is this code added before:
    <section data-customize-partial-id=”widget[gce_widget-3]” data-customize-partial-type=”widget” data-customize-partial-placement-context=”{"sidebar_id":"sidebar-1","sidebar_instance_number":1}” data-customize-widget-id=”gce_widget-3″ id=”gce_widget-3″ class=”widget widget_gce_widget”>
    My Code starts with
    <div class=”widget_right”><h3>Terminkalender</h3><div class=”simcal-calendar …
    The site I need help for is:



    I found this works sometimes and not others, it might be a caching issue, so check if you are using Autoptimize or WP Fastest Cache, or something similar that minimizes Javascript.

    Optimizing Matters


    if Autoptimize: you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there are troubleshooting tips and info on how to exclude in the AO FAQ.

    hope this helps debugging,
    frank (ao dev)

    Hi. Just downloaded this plugin and found the same bug you mention. However, it only seems to happen for me on the calendar’s actual page (ie, https://your-site/calendar/availability/)

    If you embed the calendar shortcode on a standard WP page, the back and next buttons work fine.

    If I understand correctly, you can navigate ahead to the next event, but you can’t go back if there are no events before that one. Unfortunately, I have to show this to the client when they have only one event in the calendar so far, so it looks like the plugin is broken. It seems to me that it should work just like a google calendar, where you can go back and forth on empty pages to your heart’s content. But at least I understand what’s going on now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Disabled Arrows?’ is closed to new replies.