Support » Theme: P2 » Disable auto activating the textarea

  • Whenever the page loads the textarea for posting updates automatically activates. Is there any way to disable that? How is that done?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The P2 hasn’t been updated since July 17, 2014, so it may not be compatible with the latest version of WordPress.
    Try switching to the default theme (twnty-sixteen, twenty-fifteen, etc.) and see if the same problem occurs.

    Actually, P2 was updated in October. I don’t know why it doesn’t say that on here. That doesn’t seem that old to me.

    If you’re not familiar with it, P2 adds the ability to post updates from the front-end. It also uses AJAX to display new comments/posts live without refreshing.

    The issue I’m referring to is that the textarea for making posts on the front-end automatically activates (ie. places the cursor there ready to type) when the page loads. This is fine on a desktop but on mobile it awkwardly forces the keyboard to pop up. So, yes, switching to the default theme will fix my issue but it will do so in the same way that removing the gas tank of a car fixes the problem of the gas cap constantly falling off.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    I don’t know why it doesn’t say that on here

    This post — which unfortunately I can’t sticky since the theme support forums don’t allow it — explains why.

    P2 isn’t responsive, so it’s not really geared to mobile devices and could be why this issue hasn’t been reported before. Do you notice the same issue with the revamped version of P2, which you can see on the demo here?
    https://p2breathedemo.wordpress.com/

    My apologies for taking so long to get back to you. I must have forgot to subscribe to comments.

    Anyhow, isn’t P2 Breathe only available on WordPress.com? I just tried it and the front-end post box doesn’t show on my iPhone…

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    P2 Breathe is available in an experimental form for self-hosted sites:

    https://wpcom-themes.svn.automattic.com/p2-breathe/

    You’ll need an SVN client to download it.

    The o2 plugin, which adds much of the functionality, is available here:

    https://github.com/Automattic/o2

    Huh. The last time I saw this it was really borked on self-hosted sites. It’s nice to see development going in a direction that will allow it to work other than just on WordPress.com.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Disable auto activating the textarea’ is closed to new replies.