Support » Plugin: Yoast SEO » Difficulty displaying title

  • Resolved shahinsafari

    (@shahinsafari)


    Hello
    The problem is when I publish an article
    The site name is published next to the article title
    I did not put the site name in the title

    Please fix the problem in the next update

    2- Will this Yoast Test help me if yes?
    Please give detailed instructions

    • This topic was modified 7 months, 2 weeks ago by shahinsafari.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter shahinsafari

    (@shahinsafari)

    Please synchronize the plugin with the LightSpeed plugin

    Plugin Support devnihil

    (@devnihil)

    @shahinsafari Can you please give us an example URL of one of the pages where the title is being output incorrectly, and let us know what you have set for the title for that page?

    Thread Starter shahinsafari

    (@shahinsafari)

    Yes
    I did not put the name of the site for the title of this article, but it is
    The name of my site in Persian is ظهورایمان Zohuraiman
    That is, in this article (why the arms embargo on Iran was vetoed) چرا تحریم تسلیحاتی ایران وتو شد

    site:zohouriman.ir : From the bottom of the article 3

    In some articles, I did not put the site name in the title
    But displays the site name

    The title should look like this چرا تحریم تسلیحاتی ایران وتو شد
    But it is like this چرا تحریم تسلیحاتی ایران وتو شد – ظهورایمان – سایت مذهبی ظهور ایمان

    • This reply was modified 7 months, 2 weeks ago by shahinsafari.
    • This reply was modified 7 months, 2 weeks ago by shahinsafari.
    • This reply was modified 7 months, 2 weeks ago by shahinsafari.
    • This reply was modified 7 months, 2 weeks ago by shahinsafari.
    Plugin Support devnihil

    (@devnihil)

    @shahinsafari Thanks for your reply.

    Whereas Google typically uses the title from the metadata for indexing, this is not always the case. Google will sometimes modify the title of the URL as it sees fit, as well as sometimes adding the brand or sitename to the end of your title. This is not due to the plugin not functioning as expected, but rather is due to Google modifying the Title it indexes as it’s algorithm has concluded that there is a better version to index.

    We also have additional information on this topic available at the following links: https://yoast.com/google-page-title/ and https://kb.yoast.com/kb/google-shows-different-titles-for-my-site/. Please refer to these articles as the include recommendations for crafting a page title which will help increase the likelihood that Google will use the title you specified instead of modifying your page’s title as it sees fit.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Difficulty displaying title’ is closed to new replies.