Support » Installing WordPress » Different directory problem

  • ** UPDATE **
    Never mind the question. I downloaded the CVS and found out that the installation instructions to a different directory that are posted on the website refer to THAT version rather than the last stable release. You may wish to indicate that little detail on the instructions page. 🙂
    I know I’ve seen the issue discussed before, and maybe I’m just being dense, but I can’t seem to figure how to set WP the way I want as far as directories go.
    My current MT blog is at http://benoitbisson.com/blog/index.html.
    What I am trying to do is have WordPress run the blog at the same place, so that just going to benoitbisson.com/blog will take you there once I include the php inclusion in htaccess.
    However, between what the instructions say about different directory and what is actually there, things differ and I can’t quite make out WHAT I should indicate where.
    The instructions say: Go to your Options page. It should say your WordPress address and Blog address are the same.
    Under my Options page, I assume we are talking about the one address that is specified, and that’s under Basic Settings, where there is the mention of “siteurl”. And I just cannot seem to find a place where there is mention of WordPress address. In fact, the only instance I can think of where that’s brought up is in the installation process.
    So (sorry for the length of this!), the question is simply this: if I want to have my blog address to be http://benoitbisson.com/blog/index.php, how do I go about it? What addresses do I indicate at install and in the options?

Viewing 6 replies - 1 through 6 (of 6 total)
  • i assume wp-admin/options-general.php is where you want to go:
    wp-admin | options | general
    wp and blog address both http://benoitbisson.com/blog/
    of course your wp files and dirs should be in /blog/ as well

    I have a similar problem to Benoit. I saved my WP files in the wordpress/ folder, and want my blog to live in the root directory. There are no options anywhere in my version of WP (downloaded and installed today) that match “Go to your Options page. It should say your WordPress address and Blog address are the same.” I went through all the options links… help.

    Instructions for the beta version and upwards (I am not sure about whether particular nightlies support this functionality) :
    1) Install WordPress as you normally would, following the instructions in the http://wordpress.org/docs/installation/5-minute/ installation document.
    Let us assume that your website has the URL http://www.example.com, and that you installed WordPress in the Directory wordpress (http://www.example.com/wordpress/index.php is where your blog homepage is now at), and that you want to have the index.php page (the blog) at the address http://www.example.com/blog
    2) Go to http://www.example.com/wordpress/wp-admin/options-general.php after logging in as the administrator. (‘admin’ on a fresh installation)
    3) Change the option that reads “Blog address (URI):” to read
    http://www.example.com/blog and click on the “Update Options” button.
    4) Edit the file index.php in the “wordpress” folder on your server, changing the line
    require('./wp-blog-header.php'); to be require('../wordpress/wp-blog-header.php');
    (in short, the above line should specify the relative path to the file named “wp-blog-header.php”)
    5) Move the edited file named “index.php” from the “wordpress” folder on your website’s server to the folder called “blog”, or if you edited index.php after first downloading it to your computer, then uploaded the edited index.php to the “blog” folder that you already created
    6) If you are using rewrite rules for nicer PermaLinks, go to the page http://www.example.com/wordpress/wp-admin/options-permalink.php and enter the desired Permalink structure using the tags and the help on that page, and click “Update Options” to get the new .htaccess rules. Copy the WordPress generated lines from the box, and paste them in a file called .htaccess in the “blog” directory. Create a file called .htaccess if one is not already present in that directory. Use a simple text editor such as notepad or wordpad to create the .htaccess file if you are creating it on your computer.
    7) Sit back and enjoy! Easy does it.

    Sigh… I think I’m downwards from the beta version (downloaded it from the Sourceforge link, 1.0.2). I guess it won’t work for me.
    Also, I now know my webhost doesn’t like us to mess with .htaccess, so I won’t be able to sort out the permalinks anyway.
    Ah well.

    This solution is no good, since you will not longer be able to edit the index.php through the admin interface. Anyone with some thoughts on this?

    Just wondering if anyone found a solution to this that was mentioned earlier?
    “This solution is no good, since you will not longer be able to edit the index.php through the admin interface. Anyone with some thoughts on this?”

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Different directory problem’ is closed to new replies.