Support » Plugin: BoldGrid Easy SEO - Simple and Effective SEO » Deprecated: implode(): Error

  • Resolved cpahoregon

    (@cpahoregon)


    Hi, I’m using BoldGrid Easy SEO Version 1.6.5 and after updating the Post and Page Builder plugin by BoldGrid, and adding Smush.it plugin to compress photos, I’m now getting the following error (found with WP debug set to true):

    Deprecated: implode(): Passing glue string after array is deprecated. Swap the parameters on line 111

    Here’s the code on line 111:
    $sentences = implode( $sentences, ” ) . ‘.’;

    I’m not a developer and know about enough to be dangerous in the coding realms (but I knew how to find the code in line 111, so that’s something!).

    Hoping this is an easy fix you can help me with. I’m ready to launch our new website that I just built and would love to fix the bugs before going live.

    Thanks so much!!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Jesse Owens

    (@jessecowens)

    Hi @cpahoregon
    Thanks for bringing this to our attention!
    Our developers are already working on a fix in this bug report and we’ll have an update out soon to fix this for you.

    Thread Starter cpahoregon

    (@cpahoregon)

    Wonderful, thanks so much Jesse!

    Plugin Author Brad Markle

    (@bwmarkle)

    Hi @cpahoregon – We just released BoldGrid Easy SEO Version 1.6.6, which should resolve the issue you described. Can you update and test again?

    Thread Starter cpahoregon

    (@cpahoregon)

    Hi @bwmarkle I updated the plugin and here’s what I’m getting now… it doesn’t say BoldGrid Easy SEO so does this mean your plugin is fixed and I know have an issue with WP Super Cache? Thank you for your help!

    Deprecated: strpos(): Non-string needles will be interpreted as strings in the future. Use an explicit chr() call to preserve the current behavior in /wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 654

    Warning: Cannot modify header information – headers already sent by (output started at /wp-content/plugins/wp-super-cache/wp-cache-phase2.php:654) in /wp-admin/post.php on line 231

    Warning: Cannot modify header information – headers already sent by (output started at /wp-content/plugins/wp-super-cache/wp-cache-phase2.php:654) in /wp-includes/pluggable.php on line 1281

    Warning: Cannot modify header information – headers already sent by (output started at /wp-content/plugins/wp-super-cache/wp-cache-phase2.php:654) in /wp-includes/pluggable.php on line 1284

    Plugin Support Jesse Owens

    (@jessecowens)

    Hi @cpahoregon
    Yes, you’re right that these errors are in WP Super Cache. I see you already let them know about the issue.

    As an aside, you can prevent these errors from showing up on the front-end of your website by making a few changes to wp-config.php and instead move them to a log file:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Deprecated: implode(): Error’ is closed to new replies.