Support » Plugin: Hummingbird – Speed up, Cache, Optimize Your CSS and JS » define(‘WP_CACHE’, true); error message

  • Resolved sailors

    (@sailors)


    Hi,

    I noticed an error something like that said WP super cache is installed so search for solution and found a post about WP super cache and Hummingbird compatibility, then learned no need to have both of them so cleared cache and deactivated WP super cache.

    My site still looks working fine but got another error message in the Page Caching page,
    Hummingbird could not locate the WP_CACHE constant in wp-config.php file for WordPress. Please make sure the following line is added to the file:
    define(‘WP_CACHE’, true);

    I don’t know if it is affecting negatively on my site but what would be proper solution for that error message? I deactivated WP super cache but didn’t delete it completely yet.

    Please help.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 16 through 20 (of 20 total)
  • Just sent you an Email. Please check.

    Hello,

    Did you receive my Email?

    Plugin Author calumbrash

    (@calumbrash)

    Hi @sailors,

    Apologies but Anton is currently on holiday and back this Thursday. If you can’t wait until then could you please fill out the contact form again https://premium.wpmudev.org/contact/#i-have-a-different-question with the subject Attn:Calum so the message is assigned to me.
    Sorry for the delay in response from us.

    Cheers,
    Calum Brash

    I think I just figured it out. This was the solution,

    https://wordpress.org/plugins/wp-super-cache/

    Make sure the following line is in wp-config.php and it is ABOVE the “require_once(ABSPATH.’wp-settings.php’);” line:

    define( ‘WP_CACHE’, true );

    I inserted the piece of code at the very end of the file at first but moved it before “require_once(ABSPATH.’wp-settings.php’);” line:, then the error message disappeared.

    Can you please confirm that? If that’s not right way to do please let me know.

    Plugin Author calumbrash

    (@calumbrash)

    Hi @sailors,

    Awesome work! Yes that’s correct all entries added to wp-config.php should go before the comment /* That's all, stop editing! Happy blogging. */

    I will mark this ticket as resolved 🙂

    Cheers,
    Calum

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘define(‘WP_CACHE’, true); error message’ is closed to new replies.