Support » Plugin: Decision Tree » Decision Tree Blows Up at Step #13

Viewing 8 replies - 1 through 8 (of 8 total)
  • Here’s the blob of one of the failed decision trees:

    {\"data\":{\"1\":{\"question\":\"Which operating system platform are your deploying?\",\"type\":\"question\",\"subtext\":\"You must first install the operating system of your choice.\",\"choices\":[{\"choice\":\"CentOS 6.5\",\"next\":\"5\"},{\"choice\":\"Ubuntu 14\",\"next\":\"9\"},{\"choice\":\"Raspbian 7 (Raspberry Pi 2)\",\"next\":\"18\"}]},\"5\":{\"question\":\"CentOS6.5: Which Asterisk version do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Asterisk 11 (LTS) Recommended\",\"next\":\"21\"},{\"choice\":\"Asterisk 12 (Support ends 12/31/2015)\",\"next\":\"33\"}]},\"9\":{\"question\":\"Ubuntu14: Which Asterisk version do your prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Asterisk 11 (LTS) Recommended\",\"next\":\"39\"},{\"choice\":\"Asterisk 12 (Support ends 12/31/2015)\",\"next\":\"42\"}]},\"18\":{\"question\":\"Raspbian7: Which Asterisk version do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Asterisk 11 (LTS) Recommended\",\"next\":\"48\"}]},\"21\":{\"question\":\"CentOS6.5/Asterisk11: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Incredible PBX GUI 11 (Stable)\",\"next\":\"54\"},{\"choice\":\"Incredible PBX GUI 12 (Recommended)\",\"next\":\"54\"},{\"choice\":\"Asterisk-GUI (No longer supported)\",\"next\":\"54\"},{\"choice\":\"FreePBX 2.11\",\"next\":\"54\"},{\"choice\":\"FreePBX 12 (Proprietary)\",\"next\":\"54\"}]},\"27\":{\"question\":\"Raspbian 7/Raspberry Pi 2 Recommended Platform\",\"type\":\"answer\",\"subtext\":\"Visit <a href=\\\"http://nerdvittles.com/?p=13599\\\">http://nerdvittles.com/?p=13790</a> for download and tutorial.\",\"choices\":[]},\"33\":{\"question\":\"CentOS6.5/Asterisk12: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"FreePBX 12 (Proprietary)\",\"next\":\"54\"}]},\"39\":{\"question\":\"Ubuntu14/Asterisk11: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Incredible PBX GUI 11 (Stable)Incredible PBX GUI 11 (Stable)\",\"next\":\"27\"},{\"choice\":\"Incredible PBX GUI 12 (Recommended)\",\"next\":\"27\"}]},\"42\":{\"question\":\"Ubuntu14/Asterisk12: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Incredible PBX GUI 12 (Recommended)\",\"next\":\"27\"},{\"choice\":\"FreePBX 12 (Proprietary)\",\"next\":\"27\"}]},\"48\":{\"question\":\"Raspbian7/Asterisk11: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Incredible PBX GUI 12 (Recommended)\",\"next\":\"27\"},{\"choice\":\"Asterisk-GUI (No longer supported)\",\"next\":\"27\"}]},\"52\":{\"question\":\"CentOS6.5/Asterisk11/Asterisk-GUI Recommended Platform\",\"type\":\"answer\",\"subtext\":\"Visit <a href=\\\"http://nerdvittles.com/?p=11766\\\">http://nerdvittles.com/?p=11766</a> for download and tutorial.\",\"choices\":[]},\"54\":{\"question\":\"CentOS6.5/Asterisk11/IncredibleGUI Recommended Platform\",\"type\":\"answer\",\"subtext\":\"Visit <a href=\\\"http://nerdvittles.com/?p=13599\\\">http://nerdvittles.com/?p=13599</a> for download and tutorial.\",\"choices\":[]},\"55,55\":{\"choices\":[]}},\"index\":{\"0\":\"1\",\"1\":\"5\",\"2\":\"9\",\"3\":\"18\",\"4\":\"21\",\"5\":\"27\",\"6\":\"33\",\"7\":\"39\",\"8\":\"42\",\"9\":\"48\",\"10\":\"52\",\"11\":\"54\",\"12\":\"55,55\"},\"start_ID\":\"1\",\"version\":\"1.1.0\"}

    wardmundy – thanks so much for all the information! And of course, sorry you’re having any problems.

    Can you also provide the version of WordPress and version of PHP you’re running?

    Either way, we’ll look into this and get back to you.

    Thanks for your note. At the time, I was running it on a machine with the latest version of WordPress 4.2.2 I have since moved back to the supported (but dangerous) version of WordPress but haven’t had a chance to test the Lucky 13 yet.

    wardmundy – Interesting! Indeed, when loading your data blob into my development instance, I see it is corrupt and shows the the last step as 55,55. That said, we’ve done automated testing up to 50+ steps, so it’s not to do with the number of steps, Instead, some how our plugin code isn’t properly converting your steps to JSON for storage in the DB.

    If you feel like testing some more, you could punch in each step, answer and question and save after each entry. You should notice that one of these entries causes the error. However, this is kinda a tall order, so we totally understand if you’re too busy to do this 😉

    Otherwise, we’ll continue to dig into this and keep you posted!

    wardmundy – Thought I still agree there’s a problem with your tree, I’m unable to reproduce it using your data. I manually recreated your tree and went up to step 14 with no problem. Here’s the blob which you can insert into your DB to pick up where you left off:

    {\"data\":{\"1\":{\"question\":\"Which operating system platform are your deploying?\",\"type\":\"question\",\"subtext\":\"You must first install the operating system of your choice.\",\"choices\":[{\"choice\":\"CentOS 6.5\",\"next\":\"4\"},{\"choice\":\"Ubuntu 14\",\"next\":\"9\"},{\"choice\":\"Raspbian 7 (Raspberry Pi 2)\",\"next\":\"12\"}]},\"4\":{\"question\":\"CentOS6.5: Which Asterisk version do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Asterisk 11 (LTS) Recommended\",\"next\":\"15\"},{\"choice\":\"Asterisk 11 (LTS) Recommended\",\"next\":\"24\"}]},\"9\":{\"question\":\"Ubuntu14: Which Asterisk version do your prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Asterisk 11 (LTS) Recommended\",\"next\":\"27\"},{\"choice\":\"Asterisk 12 (Support ends 12/31/2015)\",\"next\":\"31\"}]},\"12\":{\"question\":\"Raspbian7: Which Asterisk version do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Asterisk 11 (LTS) Recommended\",\"next\":\"34\"}]},\"15\":{\"question\":\"CentOS6.5/Asterisk11: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Incredible PBX GUI 11 (Stable)\",\"next\":\"40\"},{\"choice\":\"Incredible PBX GUI 12 (Recommended)\",\"next\":\"40\"},{\"choice\":\"Asterisk-GUI (No longer supported)\",\"next\":\"40\"},{\"choice\":\"FreePBX 2.11\",\"next\":\"40\"},{\"choice\":\"FreePBX 12 (Proprietary)\",\"next\":\"40\"}]},\"21\":{\"question\":\"Raspbian 7/Raspberry Pi 2 Recommended Platform\",\"type\":\"answer\",\"subtext\":\"Visit <a href=\\\"http://nerdvittles.com/?p=13599\\\">http://nerdvittles.com/?p=13790</a> for download and tutorial.\",\"choices\":[]},\"24\":{\"question\":\"CentOS6.5/Asterisk12: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"FreePBX 12 (Proprietary)\",\"next\":\"40\"}]},\"27\":{\"question\":\"Ubuntu14/Asterisk11: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Incredible PBX GUI 11 (Stable)Incredible PBX GUI 11 (Stable)\",\"next\":\"21\"},{\"choice\":\"Incredible PBX GUI 12 (Recommended)\",\"next\":\"21\"}]},\"31\":{\"question\":\"Ubuntu14/Asterisk12: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Incredible PBX GUI 12 (Recommended)\",\"next\":\"21\"},{\"choice\":\"FreePBX 12 (Proprietary)\",\"next\":\"21\"}]},\"34\":{\"question\":\"Raspbian7/Asterisk11: Which GUI do you prefer?\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"Incredible PBX GUI 12 (Recommended)\",\"next\":\"21\"},{\"choice\":\"Asterisk-GUI (No longer supported)\",\"next\":\"21\"}]},\"37\":{\"question\":\"CentOS6.5/Asterisk11/Asterisk-GUI Recommended Platform\",\"type\":\"answer\",\"subtext\":\"Visit <a href=\\\"http://nerdvittles.com/?p=11766\\\">http://nerdvittles.com/?p=11766</a> for download and tutorial.\",\"choices\":[]},\"40\":{\"question\":\"CentOS6.5/Asterisk11/IncredibleGUI Recommended Platform\",\"type\":\"answer\",\"subtext\":\"Visit <a href=\\\"http://nerdvittles.com/?p=13599\\\">http://nerdvittles.com/?p=13599</a> for download and tutorial.\",\"choices\":[]},\"43\":{\"question\":\"13th answer, is safe!\",\"type\":\"answer\",\"subtext\":\"\",\"choices\":[]},\"54\":{\"question\":\"14th question pointing to 13 answer\",\"type\":\"question\",\"subtext\":\"\",\"choices\":[{\"choice\":\"12\",\"next\":\"43\"}]}},\"index\":{\"0\":\"1\",\"1\":\"4\",\"2\":\"9\",\"3\":\"12\",\"4\":\"15\",\"5\":\"21\",\"6\":\"24\",\"7\":\"27\",\"8\":\"31\",\"9\":\"34\",\"10\":\"37\",\"11\":\"40\",\"12\":\"43\",\"13\":\"54\"},\"start_ID\":\"1\",\"version\":\"1.1.0\"}

    I manually compared the two trees and can see where the data is corrupt but, like I said, I’m still unable to see how the data would get into this munged state.

    Though I’m marking this as “resolved”, please keep us up to date. If you find a way to reliably reproduce the problem, we’d really love to hear about it.

    wardmundy – Any updates? We’d love to know if you’re still using out plugin and if the corrupt JSON problem you reported has still been problematic.

    Thanks!

    Zingtree

    (@zingtree)

    If you’re looking to build larger trees, with a more robust set of tools, try Zingtree.

    Zingtree has a WordPress plug-in, both form-based and visual editors, and several rendering options. You can also get analytics on how your trees are used.

    Plugin Author Sidecar TV, Plugin Developers

    (@sidecar)

    Hey Zingtree! Welcome to WordPress: I see you posted Version 1.0 5 months ago and and the 2 months ago updated to 2.0 of your plugin.

    One point of feedback: It’s not cool to advertise yourself on other plugin’s support forums. Please don’t do it!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Decision Tree Blows Up at Step #13’ is closed to new replies.