Support » Plugin: Yoast SEO » Debug notice

  • Resolved DS

    (@dosolnce)


    Debug swears:
    “The WP_Scripts::localize function is called incorrectly. The parameter $l10n
    must be an array. To pass arbitrary data to scripts, use
    the wp_add_inline_script() function.
    For more information, see the “Debugging in WordPress” page. (This message was added in version 5.7.0.) ../wp-includes/functions.php on line 5313.”
    I found $l10n in class-field-company-info-missing.php:
    Line 21: $l10n_data = WPSEO_Language_Utils::get_knowledge_graph_company_info_missing_l10n();,
    Line 23: $this->set_property( 'message', $l10n_data['message'] );,
    Line 24: $this->set_property( 'link', $l10n_data['URL'] );

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hi @dosolnce

    Is this occurring on your website and is it using the latest version of WordPress 5.7.2 and Yoast SEO for WordPress 16.2?

    We do have an article here on how to write and submit a bug report. We would appreciate it if you could submit it to GitHub for further investigation – https://yoast.com/help/how-to-write-a-good-bug-report/

    Thread Starter DS

    (@dosolnce)

    Hi. Yes, WordPress 5.7.2 and Yoast SEO for WordPress 16.2. I’ll try, but I don’t know enough English to write reports.

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Thanks for doing that and trying to create the bug report with as many details as possible. If anything is unclear from the help article, do let us know.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.