Support » Plugin: Really Simple SSL » Deactivation problem

  • The plugin has changed the .htaccess file and deleted the 301 redirect code although I deactivated by the plugin’s button. If I haven’t controlled the file pages would give 404 error. May be it is a useful plugin I’m not sure but be careful while deactivating.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @boragursel,

    Sorry to hear you ran into an issue! To prevent this, I have added the text “deactivate and revert to http” with the deactivation button.

    The deactivation is built to enable users to fully remove all changes.

    To deactivate the plugin but keep the site on https. You can find this option in settings/ssl.

    This button is labelled “deactivated and keep https”.

    If you have any suggestions how to make this clearer, just let me know.

    Hi @rogierlankhorst

    I deactivated by the button. I also didn’t understand and now I get 404 errors which seems the site address (kilsanblog.com) appended at the end of the urls like this:

    /yesil-cevreci-ekolojik/permakultur-doga-ile-butunlesme/kilsanblog.com

    Is it related with deactivation I really couldn’t understand.

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @boragursel,

    Thanks for your reply.

    When you deactivate using this button, the .htaccess is not changed, only the plugin is deactivated. Did you enable the .htaccess redirect in settings/ssl before deactivating? If you only used the default redirect, this does not work when the plugin is deactivated, because it is a php redirect.

    I just checked your site, but don’t get any 404 issues, is it possible this is a caching issue in your browser? Can you try clearing your browser history?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Deactivation problem’ is closed to new replies.