Support » Plugin: WooCommerce » Database update stuck

  • Resolved Soprano

    (@soprano)


    Hey,

    After the last update to woocommerce, I was asked to update my woo database in the background which I accepted. Now I have this notification bar at the top of my admin:

    “WooCommerce database update – WooCommerce is updating the database in the background. The database update process may take a little while, so please be patient.”

    It’s been a few days so I think it’s stuck. I run manual Cron jobs every half hour which I don’t know if this may have influenced the update.

    My system statys says: WooCommerce database version: 3.5.8 (which I don’t know if it’s the latest one).

    I asked premium support via woocommerce.com and they told me to disable and reenable Woo and that would regenerate the tables? I disabled Woocommerce and my whole backend was inaccessible with an error 500 code (It’s only after I disabled all the plugins via ftp that I could access the backend).

    The notification bar is still there though and I’m not sure what else to do.

    Thank you.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Support Orry F. a11n

    (@orhanf)

    Hi @soprano,

    Thank you for sharing those details!

    I have reached out to you, via ticket, regarding this concern. Kindly reply through said ticket at your earliest convenience.

    Cheers!

    What should everyone else do who is also encountering this same issue? There used to be a link that said, “run update now” to get around this. But now that’s gone. It’s been “updating” for days and re-activating the plugin doesn’t fix it.

    What are we to do? WooCommerce is updating the database in the background. The database update process may take a little while, so please be patient.

    Orry Fernandes (@orhanf) can you share the fix with us?

    same problem! in previous versions the database update lasted only a few seconds, now the warning does not disappear anymore

    Is there any fix for this? I’m having the same issue.

    Same issue here. And my payment gateway is receiving a timeout with no response from WordPress. Please help!

    Same here. What I did to get rid of the message:
    In your WP-backend go to WooCommmerce > Status > Scheduled Actions. My hooks were pending. I choose to run them by hand, one by one. Now everything seems to work fine.

    Except for one hook “woocommerce_update_marketplace_suggestions”. This one I can’t run by hand. Let it run now multiple times, but it remains pending.

    It now says database update completed.

    @nikkimartz I also received a 500 error after the payment. But I found out that when I turn off the W3-Cache plugin, the payment is working fine.

    Same problem here after updating to version 3.6.1. Normally the message changes very quickly to ‘database update complete’ but now it keeps on saying that it’s updating in the background, please be patient.

    Next to this, the webshop is working, so I am not sure if it’s a message issue error or a real database issue.

    Same problem happen. Even I did as per @pvan3 but still message prompt.

    Attention: Orry Fernandes (@orhanf)
    And others veteran.

    Could you please suggest, how to get rid from this?

    Thanks.

    Same Problem here! I cant channge anything and my home page is broken! I tried to take it back to an older version but still the same problem!

    @pvan3 that removed the message for me as well, thank you! But I am still getting the errors when Authorize.net tries to communicate with WooCommerce. Authorize has verified it’s not them…. waiting on WooCommerce to find a solution

    Guys, never make updates on your live website! Always have a copy and use it to test these changes. This is how I do it and after noticing this issue I didn’t run the update on my live website.
    I’d still like to get a fix for it though.

    Any fix to this yet????

    Thread Starter Soprano

    (@soprano)

    I got a response from premium support via Woocommerce.com.

    It seems like it’s been reported as a bug: https://github.com/woocommerce/woocommerce/issues/23414

    I was suggested to follow @pvan3 suggestion (though apparently I have 333 tasks queued so it’ll take some time) or “I would also encourage you to follow my colleagues suggestions of disabling all plugins except WooCommerce and doing the update again using the url:
    https://YOURURL.com/wp-admin/admin.php?page=wc-settings&do_update_woocommerce=1”

    I hope this helps someone, I’m going to try it now.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Database update stuck’ is closed to new replies.