Support » Installing WordPress » Database setup with PHPmyadmin

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello,

    The default privileges are usually empty as you say for each server admin to set them up as he likes depending on the situation. That is why you get an error. The minimum ones are, Select, Delete, Insert, Update and this goes for a secure setting environment lets say that you could use but that would give you a headache in the future as a new user because you would have to alter them depending on the plugins you want to have and what they want to do with your database etc.

    What I usually do is create a user for WordPress only and give him full access to the database ( meaning check everything ). With that in mind I just make sure to keep daily backups if anything goes sideways.

    That would be the simplest option to start your WordPress experience I guess.

    Best regards,
    Konstantinos

    Thanks so much!
    I made a user with full access but still getting the same error. I was able to set up a local version on my computer and installation worked.
    I am now thinking the problem is setting up the database on my hosts server. I am not sure that I have access so will contact them. I am hosted through my school’s website so unfortunately it doesn’t seem to be as easy to access as using bluehost etc.

    Hi @mcmaci,

    Did you check database credentials are correct?

    Yes, I did. It was a problem with the database on the server end.
    Thanks for the help

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.