Support » Plugin: Cart Notices for WooCommerce » Database errors when using your plugins

  • Resolved artyus

    (@artyus)


    Greetings!

    I don’t seem to have very good news.

    I tested several of your plugins and at the moment I left two of them for use on the site: Cart Notices for WooCommerce 3.5.1 and Min and Max Quantity for WooCommerce 1.2.12.1 – these are free versions.

    The site is under construction, so I have the opportunity to configure and test its parameters on live hosting.

    Yesterday I ran into the fact that I could not import the database through the hosting using phpMyAdmin. Each attempt ended with an error (attached screenshot). As I understand it, this is from your plugins:

    Duplicate entry '_transient_timeout_berocket_framework_plugin_is_active_12' for key 'option name'

    The situation was complicated by the fact that I before to clear the database. Therefore, it was impossible to use the WordPress administration panel and the backup recovery plugin to load the database.

    I tried several different database backups, but this error always appeared. And only when I used an earlier copy of the database (made on the site version before installing your plugins), I could to load database.

    After that, I was able to enter the WordPress Console and download the latest version of the database through the UpdraftPlus backup plugin that I use. It was possible to do this, although, as I said, through phpMyAdmin this copy of database was not loaded.

    Over the past two years, I have configured and selected plugins for several sites, made dozens (if not hundreds) of backups and restores of both databases and the rest of the content of sites. However, I have never encountered errors when using phpMyAdmin.

    Agree, this is very unpleasant if you cannot restore the database (moreover, directly through the hosting) due to some errors that occurred in the data of the plugin, which in no way has any relation to the backup. If I didn’t have the old version of the database, I would have to reinstall the site again. It’s a good what I’m testing now. But if this happened on the a working site?

    Please check what is the reason. If using your plugins leads to corrupt database backups and the inability to use them, no one will use them. It will be very sorry, because your developments is very interesting.

    The configuration of the site on which the error was detected, and software:

    WordPress: 5.2.4
    Theme: Weaver Xtreme 4.3.2.1
    WooCommerce: 3.7.1
    Server: Apache
    PHP: 7.3.2
    cURL: 7.47.2, OpenSSL/1.0.2k

    Cart Notices for WooCommerce: 3.5.1
    Min and Max Quantity for WooCommerce: 1.2.12.1.
    UpdraftPlus – Backup/Restore: 1.16.20
    _______________

    I hope the reason will be found.

    • This topic was modified 1 month ago by artyus.
    • This topic was modified 1 month ago by artyus. Reason: grammar
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Dima Holovnia

    (@dholovnia)

    Hi,

    We are using transients via the WordPress functions eg set_transient. You can check here https://codex.wordpress.org/Function_Reference/set_transient how it works.

    If a transient exists, this function will update the transient’s expiration time.

    The field in the database is unique so you cannot have 2 rows with the same name. If you just copy it there couldn’t be duplications. The real question is – How did you make the database backups? Did you use some plugin/service for this?

    Regards,
    Dima

    artyus

    (@artyus)

    To create the specified copy, the UpdraftPlus – Backup/Restore plugin was used.

    For my sites are also used automatic backups on the hosting, but (as I understand) it no have a separate management of a separate database and in fact I keep them exclusively for case of emergency. In this case, I have not used this.

    What is confusing is that, after all, for sure, other plugins also use the function you mentioned. But before, there were no such problems with any other plugin.

    In addition, as I said, I specially cleaned up the database before importing the backup in order to avoid conflicts. It turns out that the duplicate row was originally in the created backup? But then your plugin works with a table in which a duplicate somehow appears.

    I will continue testing, but so far the situation is.

    When using the search ‘transient_timeout_berocket’ in the database, only two lines appear (screenshot).

    Regards,
    Farid Taziev.

    • This reply was modified 1 month ago by artyus.
    Plugin Author Dima Holovnia

    (@dholovnia)

    Farid,

    Original database cannot contain 2 same rows in discussed table. So or you had our plugin active before importing and it created that row again before the import or UpdraftPlus made something wrong during backup.

    Regards,
    Dima

    Yes, there was something incomprehensible. But no longer repeated.

    Also, just in case, I configured the cleaning of expired transients.

    Thanks.

    Yours faithfully,
    Farid Taziev.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.