Support » Plugin: WooCommerce » Dashboard is blank WooCommerce Admin

  • Resolved RobWord

    (@robword)


    Hi
    I was informed this morning of the new dashboard for WooCommerce and I installed it. However, even though I get the javascript poppets for the reviews, orders , etc from the side panel, the link to the DashBoard leaves a blank page. Can you tell me if this is a bug, if there is a fix?
    Thanks

    Rob

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support madeincosmos

    (@madeincosmos)

    Automattic Happiness Engineer

    Hi @robword,

    I just tested the same thing on my site, and the new dashboard is loading correctly there:

    Screenshot: https://cld.wthms.co/YxQF57

    Are you seeing any JavaScript errors on the Dashboard page? You can press F12 on Windows or Command + Options + I on Mac to open the browser console and check. Here is an example of what we’re looking for:

    Screenshot: http://cld.wthms.co/MfEC

    You can also check WooCommerce > Status > Logs for a file that starts with fatal-errors, in case there are some problems on the server level.

    Cheers!

    Hi
    I checked the console and no WooCommerce related errors. I checked the logs and nothing in there with fatal-errors.
    I looked at the status page and all seems good.
    As I said all javascript based plugins work and I do get the side poppet element in the new admin plugin, just not the dashboard.

    Plugin Support madeincosmos

    (@madeincosmos)

    Automattic Happiness Engineer

    @robword thanks for checking this! As I’m unable to reproduce the same problem on a test site, the next thing you can check is to test if some other plugin or theme could be interfering with the dashboard. If you’d rather avoid deactivating things on your real site, you can create a test copy using the free **WP Staging** plugin:

    https://wordpress.org/plugins/wp-staging/

    Once you’re there, please switch to a default theme, deactivate all plugins except for WooCommerce & WooCommerce Admin and see if it solves the problem. If it does, you can activate them back 1 by 1 until the dashboard starts breaking again.

    OK

    That was quite easy, it was a plugin at the bottom of the list (lucky I started backwards). The plugin that has a conflict is: WPSSO Core Pro [Main Plugin]

    OK

    Plugin Support madeincosmos

    (@madeincosmos)

    Automattic Happiness Engineer

    Great, I can see the plugin authors are active on their forum so you can let them know about this problem here:

    https://wordpress.org/support/plugin/wpsso/

    OK, and I will let you know of they are not willing to do a fix, I guess.

    Hi
    I communicated with the plugin author and like most they pass the Balme. I read what he said and put into affect all his advise, but I am an artist not a web tech, so I have no idea what I am looking for.
    This is what he wrote:
    “It happens on occasion that WPSSO will trigger bugs in other applications, especially if the SSO > Advanced > Content and Filters > Use WordPress Content Filters option is enabled, for example.

    I would suggest you set the WP_DEBUG constant to true (this is fairly standard and there are many how-tos on Google about this) and activate the Query Monitor plugin. This combination will report any PHP related issues.”

    The WooCommerce Admin plugin appears to use a lot of javascript/jQuery and Ajax calls, so you may want to enable the console feature in your web browser as well.

    You can find more information here: https://wpsso.com/docs/plugins/wpsso/installation/debugging-and-problem-solving/

    If you can tell me what I am looking for in the Query Monitor plugin that would be a start.

    Thanks

    Rob

    Good Day I have the same problem and the console shows tow errors bellow

    [Error] TypeError: undefined is not an object (evaluating ‘this.style.setProperty’)
    (anonymous function) — index.js:27:289045
    each — index.js:27:295568
    ds — index.js:27:334213
    value — index.js:27:341685
    value
    value — index.js:27:299114
    value — index.js:27:298376
    qi — react-dom.min.js:3265
    ui — react-dom.min.js:3386
    (anonymous function) — react-dom.min.js:4141
    unstable_runWithPriority — react.min.js:27
    Vc — react-dom.min.js:4140
    Sc — react-dom.min.js:4128:191
    Z — react-dom.min.js:4095
    Kc — react-dom.min.js:4032
    ya — react-dom.min.js:3983:94
    enqueueSetState — react-dom.min.js:5298
    setState — react.min.js:20:449
    value — index.js:48871:101
    value
    forEach
    n — data.min.js:1:11640
    forEach
    setState — index.js:17372:126
    (anonymous function) — index.js:86489
    m — index.js:86364
    dataReceived — index.js:86480
    dataReceived — index.js:17508
    (anonymous function) — index.js:17478:83
    d — index.js:61565
    (anonymous function) — index.js:61547
    a — index.js:15555
    c — index.js:15569
    promiseReactionJob

    Bg (react-dom.min.js:117:156)
    callback (react-dom.min.js:126)
    Ag (react-dom.min.js:116:410)
    zg (react-dom.min.js:116:151)
    qi (react-dom.min.js:131)
    ui (react-dom.min.js:133:323)
    (anonymous function) (react-dom.min.js:158:380)
    unstable_runWithPriority (react.min.js:27)
    Vc (react-dom.min.js:158:363)
    Sc (react-dom.min.js:158:147)
    Z (react-dom.min.js:156:495)
    Kc (react-dom.min.js:155)
    ya (react-dom.min.js:153:162)
    enqueueSetState (react-dom.min.js:202:412)
    setState (react.min.js:20:449)
    value (index.js:27:515255)
    value
    forEach
    n (data.min.js:1:11640)
    forEach
    setState (index.js:14:103264)
    (anonymous function) (index.js:53:489081)
    m (index.js:53:486901)
    dataReceived (index.js:53:488944)
    dataReceived (index.js:14:106934)
    (anonymous function) (index.js:14:106299)
    d (index.js:27:837451)
    (anonymous function) (index.js:27:837236)
    a (index.js:14:64182)
    c (index.js:14:64385)
    promiseReactionJob

    can you please help?

    • This reply was modified 4 weeks, 1 day ago by  jadmx.
    Bill Daubenmier

    (@billdpcdataworkscom)

    I also have a blank page on the Dashboard using WooCommerce Admin version 0.81. I have disabled WooCommerce Blocks 2.4.0 and my problem is solved.

    Cheers,
    Bill

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.