Support » Plugin: ConverseJS » Custom variable syntax

  • Resolved gyulavitez

    (@gyulavitez)


    Hello. I want to customize the plugin with the custom variable box. But I can’t find a description which works. If I input something like: view_mode: mobile nothing happens and the chat box is disappearing from the site.
    The documentation here: Link isn’t help me either. I think this is valid only for php code.
    Please write some example how to use the Custom Variable box.
    My main goal is to activate mobile view first.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Thomas Camaran

    (@camaran)

    Hi, in custom variable box you can set any variable Variable documentation but not view_mode for a bug of conversejs 3.3.1

    We think to release a version of plugin with conversejs 3.3.3 soon.

    for example:
    allow_contact_requests:true,

    Plugin Author Thomas Camaran

    (@camaran)

    Soon i think to add option for manage view_mode directly from option page 🙂

    Thank you for the quick answer and for the great plugin.
    Waiting for an update then.

    Plugin Author Thomas Camaran

    (@camaran)

    please download trunk version with auto view_mode setting and send me a feedback for this version

    ok, I have updated the plugin. The mobile view is different slightly. The name changed to InVerse – I think this is the mobile css, but it’s full screen again.
    What is the expected size of the window? I tried Firefox and Samsung browser.
    Full screen chat window is big for mobile I think.
    I’ve enabled “hide chat panel open”, but it doesn’t seem to affect the outcome. In the previous version, the chat panel was minimised.

    Plugin Author Thomas Camaran

    (@camaran)

    infact if i set view_mode: mobile not work hide chat panel open for a bug of converse you can see here.

    Please download again trunk i commited a version with view_mode remove i think now hide chat panel open work

    So the view-mobile function is still waiting to be fixed by the main dev.
    I’ll follow the issue. Thanks.

    Hi! I don’t know if I should post it here:
    I’ve got problem with playing sounds in the chat. If I thick the “play sounds” nothing happens. The setting doesn’t get stored. I’ve tried several path options: full path(/wp-config…), /sounds/, ./sounds, etc.
    I’ve tried the “play_sounds:true,” variable.

    I see you updated the plugin, is there any changes after the one week old trunk version(you posted before)?

    Plugin Author Thomas Camaran

    (@camaran)

    bug of options page, fixed in 3.3.3.1 version

    Thank you. Should I enter some kind of sound path? Or use the ./sounds?
    I still doesn’t get any sound. I’ve checked the files, they are there. Permissions are ok.

    Plugin Author Thomas Camaran

    (@camaran)

    you try with absolute path

    Still no success. What am I doing wrong?
    I’ve tried in the Sound Path box:
    /wp-content/plugins/conversejs/core/sounds/ (and without the last dash /)
    https://site-name/wp-content/plugins/conversejs/core/sounds/
    /sounds/
    ./sounds
    /var/www/…
    Custom variable:
    sounds_path:same as above
    PS: I’m using Firefox

    • This reply was modified 2 years, 1 month ago by gyulavitez.
    Plugin Author Thomas Camaran

    (@camaran)

    the sound work only when you receive a message and the focus is not on the chat tab

    Plays a notification sound when you receive a personal message or when your nickname is mentioned in a chat room.

    Inside the ./sounds directory of the Converse.js repo you’ll see MP3 and Ogg formatted sound files. We need both, because neither format is supported by all browsers.

    Thank you, problem solved. My mistake.

    Plugin Author Thomas Camaran

    (@camaran)

    Good news

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Custom variable syntax’ is closed to new replies.