WordPress.org

Support

Support » Plugins and Hacks » Custom Post Type Missing

Custom Post Type Missing

  • Suddenly a client who is running Easy Post Types 1.1 is no longer seeing the custom post type in the admin menu, and the posts themselves are missing. They are in the database, but not accessible via the admin. Custom queries are pulling the data, but the permalinks are putting them under the “uncategorized” blog category now, which causes the single post type template to break. I don’t see the post type or custom taxonomies listed in the Easy Post Types admin. Is there any way to fix that without having to start from scratch? I’m scared to update the plugin, as it seems something has gone awry with the WP database.

    http://wordpress.org/extend/plugins/easy-post-types/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Never mind, folks. Rackspace had moved the site to a new storage node, then taken it upon themselves to do a global search and replace for the old file paths in MySQL. That broke the plugin. I was able to find the DB record in MySQL that had the Easy Post Types config data, and re-replace with the old file paths and we’re back up and running again.

    And… the DB record in question is in wp_options, option_name = ct_content_types, just in case anyone else runs into this. Change back any absolute file paths to your old storage node path and it will bring back your custom post types/taxonomies/fields.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Custom Post Type Missing’ is closed to new replies.