Support » Plugin: 404page - your smart custom 404 error page » Custom 404 page stopped working

  • This plugin was working fine but now it no longer directs to my custom 404 page. I am on WordPress 5.1.1 and I also have WPML installed so it’s a dual-language site. It was working fine previously but something changed recently, unfortunately I’m not sure when. Is anyone else having this issue or having trouble with WPML?

Viewing 6 replies - 1 through 6 (of 6 total)
  • pelicani

    (@pelicani)

    We are also experiencing issues after updating from 10.5 to 11.3.
    We are using WP 5.2.3
    We are also using WPML.

    The 404 page for this plugin is not loading.

    Our Error …
    [Tue Sep 10 15:42:21.956484 2019] [php7:error] [pid 16275] [client 34.207.79.107:54800] PHP Fatal error: require_once(): Failed opening required ‘/nas/content/live/project/wp-content/plugins/404page/inc/class-404page.php’ (include_path=’.:/usr/share/pear/php:/usr/share/php’) in /nas/content/live/project/wp-content/plugins/404page/loader.php on line 26

    We confirmed this class-404page.php file exists.

    Our site is running on several different environments.
    It’s working fine on my local, but WordPress Engine Staging is failing.

    Hope this helps identify a path for fixing.

    • This reply was modified 3 months ago by pelicani.

    I recently updated the plugin again and it’s still not working. Wrote to the developer of the plugin, hopefully there is a way to fix it.

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Sorry, there was a bug in version 11.0.x concerning WPML compatibility. Fixed in version 11.0.4. Please update and let me know if it works.

    Regards,
    Peter

    Thank you for your reply. I updated to 11.0.4 but unfortunately it does not work for our site.
    It shows the default 404 page instead of our custom one, even when I go back into settings and hit Save again.

    Plugin Author Peter Raschendorfer

    (@petersplugins)

    Plugin compatibility is officially approved by WPML team. They retested version 11.0.4 on October, 7 and confirmed compatibility. It also works fine on my testing machine. There must be conflict with the theme you’re using or another plugin.

    Please follow this checklist https://wordpress.org/support/topic/please-read-this-before-posting-a-new-topic and inform me about the results.

    Regards,
    Peter

    Ok thank you, I will check it out.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.