Support » Fixing WordPress » Critical Errors

  • Resolved neotechnomad

    (@neotechnomad)


    Getting critical errors since update to 5.6.

    The following are from Firefox debugger.
    Have screenshots if required.

    When loading site:

    wp-includes/js/jquery > jquery.js
    
    // Support: Firefox <=3.6 - 5 only
    // Old Firefox doesn't throw on a badly-escaped identifier.
    el.querySelectorAll( "\\\f" );
    rbuggyQSA.push( "[\\r\\n\\f]" );
    
    Paused on exception
    SyntaxError: Element.querySelectorAll: '\' is not a valid selector

    When logging in:

    Paused on exception
    SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

    Reloading site sometimes clears issue, sometimes not. Occurs intermittently throughout site pages/posts.
    Reloading login initially clears issue but can intermittently reoccur when navigating site admin. Reloading page loads it.

    WordPress 5.6
    PHP 7.4.11

    Disabled all plugins and activated one by one. Error did not disappear.
    Via FTP, deleted WordPress core directories and files and uploaded from fresh download.
    Issue still occurs.

    Please investigate.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter neotechnomad

    (@neotechnomad)

    I have checked with other sites that I administer that are running versions of PHP 7.3 and no Critical Errors occur on these sites. All of these sites have the same plugins installed as the site running PHP 7.4.
    I am assuming that this is an issue between WordPress 5.6 and PHP 7.4.

    Also, updating plugins and/or themes throws a critical error nor can I run a backup to Dropbox with this plugin: BackWPup. Tried to backup several times and it threw a citical error each time.

    Thread Starter neotechnomad

    (@neotechnomad)

    This appeared when loading site:

    Fatal error: [snuffleupagus][disabled_function] Aborted execution on call of the function 'curl_setopt', because its argument '$option' content (81) matched the rule 'Please don't turn CURLOPT_SSL_VERIFYHOST off.' in /home/mysticsi/public_html/wp-includes/Requests/Transport/cURL.php on line 150

    It states in “Debugging in WordPress” (https://wordpress.org/support/article/debugging-in-wordpress/):

    WP_DEBUG_LOG is a companion to WP_DEBUG that causes all errors to also be saved to a debug.log log file This is useful if you want to review all notices later or need to view notices generated off-screen (e.g. during an AJAX request or wp-cron run).
    
    Note that this allows you to write to log file using PHP’s built in error_log() function, which can be useful for instance when debugging Ajax events.
    
    When set to true, the log is saved to debug.log in the content directory (usually wp-content/debug.log) within your site’s filesystem. Alternatively, you can set it to a valid file path to have the file saved elsewhere.

    The debug log does not appear in any directory within “public_html” at all.

    Finally found this in “/logs” outside of “public_html”:

    [29-Dec-2020 07:57:05 UTC] PHP Fatal error: [snuffleupagus][disabled_function] Aborted execution on call of the function 'curl_setopt', because its argument '$option' content (81) matched the rule 'Please don't turn CURLOPT_SSL_VERIFYHOST off.' in /home/mysticsi/public_html/wp-includes/Requests/Transport/cURL.php on line 150

    There is obviously an error in the cURL.php file in wp-includes which needs to be fixed.

    [ Please do not bump. ]

    Hi! Unfortunately, you bumped your post yourself… your comments also count.

    You need to address this issue to your hosting provider because it looks like they tightened security in a way which isn’t fully compatible with WordPress. Most hostings have fully compatible with it and keeping up with requirements of the system and even provide one-click installation, so, it’s supposed they will know what needs to be changed on server settings to make WordPress work fine.

    Thread Starter neotechnomad

    (@neotechnomad)

    Thanks, @oglekler

    I figured that I had bumped myself when I added the comments. 🙁

    Also, I concluded that it is my host as I installed WordPress w/o plugins on another server on the same host and there was no critical error. Then I installed all my normal plugins and still no error.

    So, this concerns my host, not WordPress, and I shall mark this resolved.

    Thanks again, @oglekler 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.