Support » Plugin: Video Sales for Woocommerce with Vimeo » Critical Error WP

  • Resolved Matt

    (@braquopronos)


    Hello,

    First thanks for developping this plugin.

    I have an issue with it, i have setup everything on vimeo & wordpress (api etc) but i have a critical error while in vimeo’s tab in product section.

    Logs : Parse error: syntax error, unexpected ‘?’ in /wp-content/plugins/wc-vimeo/vendor/vimeo/vimeo-api/src/Vimeo/Vimeo.php on line 163

    • This topic was modified 2 years, 3 months ago by Matt.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Same problem here ! Have you found a solution?

    I have the solution ! The hosting of the site must run under a version of PHP higher than 7.1

    Plugin Author Vincent

    (@vincentastolfi)

    @devoctopix @braquopronos Sorry about that. I never got notified about these posts and haven’t checked back here in a while. I’ll try to get this updated for you so it can work with PHP 7.2.

    Plugin Author Vincent

    (@vincentastolfi)

    @braquopronos and @devoctopix I have updated the library where the error was occurring. It looks like the Vimeo API was out of date. This should work now on 7.2, let me know if you are still having issues.

    Plugin Author Vincent

    (@vincentastolfi)

    https://github.com/vastolf/woocommerce-vimeo

    You can download the latest there

    One of the Vimeo API’s dependencies is using a method that the WordPress plugin repo doesn’t like. But you can get 0.0.4 there for now until they update, have contacted the maintainers of the dependency.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Critical Error WP’ is closed to new replies.