Support » Plugin: SharDB » connection Error

  • My db-settings
    $shardb_hash_length = 1;
    $shardb_prefix = ‘old_wordpress_’;
    $shardb_dataset = ‘wordpress’;
    $enable_home_db = true;
    $shardb_local_db = true;

    data has been migrated into global and home table but when I added db.php file, its shows folloing error..

    Notice: SharDB was called incorrectly. SharDB must set a database connection for use with escaping. Please see Debugging in WordPress for more information. (This message was added in version 1024.) in C:\wamp\www\wordpress3_9\wp-includes\functions.php on line 3249

    https://wordpress.org/plugins/shardb/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Were the rest of the tables migrated?

    Please I have bought the document, so I still have error

    Error: You must configure your database settings by adding require('./db-settings.php'); to your /hsphere/local/home/bbblzxh/jounalib.com/wp-config.php for the migration process to work

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    @guenscher you need to add that line to your wp-config.php. See https://codex.wordpress.org/Editing_wp-config.php

    I have added it, but still show the same thing

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Where did you add it? It should be right after your DB constants:

    define( 'DB_...', '....' );

    If that is where you placed it then did you edit the settings lines in place in db-settings.php? Those lines are wrapped in a multi-line comment. You need to copy those lines outside the /* and */.

    I have added it afte this line

    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    My debugs here

    Notice: Undefined variable: shardb_prefix in /home/karrito1/public_html/db-settings.php on line 91

    Notice: Undefined variable: slaves in /home/karrito1/public_html/db-settings.php on line 96

    Notice: Undefined variable: enable_home_db in /home/karrito1/public_html/db-settings.php on line 189

    Plugin Author Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    @guenscher – the sample configuration settings in db-settings.php are commented out. Copy your settings to after the */.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.