Support » Plugin: Postie » Connecting after upgrading to 1.5

  • Resolved transom

    (@transom)


    After upgrading to 1.5 this weekend, it appears that I am no longer connecting to my email server.

    [08-Apr-2013 17:17:09 UTC] Postie: Starting mail fetch
    [08-Apr-2013 17:17:09 UTC] Postie: Time: 2013-04-08 17:17:09 GMT
    [08-Apr-2013 17:17:09 UTC] Postie: wp_content_path: /home/--deleted--/--deleted--.com/wp-content
    [08-Apr-2013 17:17:09 UTC] Postie: Connecting to mail.--deleted--.com:110 (pop3)
    [08-Apr-2013 17:17:09 UTC] Postie: message count: 0
    [08-Apr-2013 17:17:09 UTC] Postie: There are 0 messages to process
    [08-Apr-2013 17:17:09 UTC] Postie: memory at start of e-mail processing:27545280
    [08-Apr-2013 17:17:09 UTC] Postie: Error log: /home/--deleted--/--deleted--.com/wp-content/debug.log
    [08-Apr-2013 17:17:09 UTC] Postie: memory at end of e-mail processing:27545176
    [08-Apr-2013 17:17:09 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/--deleted--/--deleted--.com/wp-includes/functions.php on line 2923
    [08-Apr-2013 17:17:09 UTC] PHP Notice:  has_cap was called with an argument that is <strong>deprecated</strong> since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/--deleted--/--deleted--.com/wp-includes/functions.php on line 2923
    [08-Apr-2013 17:17:09 UTC] Postie: Error log: /home/--deleted--/--deleted--.com/wp-content/debug.log
    [08-Apr-2013 17:17:09 UTC] Postie: Postie is in /home/--deleted--/--deleted--.com/wp-content/plugins/postie
    [08-Apr-2013 17:17:09 UTC] Postie: iconv: installed
    [08-Apr-2013 17:17:09 UTC] Postie: imap: installed
    [08-Apr-2013 17:17:09 UTC] Postie: mbstring: installed
    [08-Apr-2013 17:17:09 UTC] Postie: post date: 2013-04-08 17:17:09 / 2013-04-08 17:17:09
    [08-Apr-2013 17:17:09 UTC] Postie: GMT: 2013-04-08 17:17:09
    [08-Apr-2013 17:17:09 UTC] Postie: Current: 2013-04-08 17:17:09
    [08-Apr-2013 17:17:09 UTC] Postie: checking
    [08-Apr-2013 17:17:09 UTC] Postie: Sucessful POP3 connection on port 110
    [08-Apr-2013 17:17:09 UTC] Postie: Unable to authenticate. The server said:
    [08-Apr-2013 17:17:09 UTC] Postie:

    Using telnet works just fine

    onebigidea:~ transom$ telnet mail.--deleted--.com 110
    Trying 208.97.132.231...
    Connected to mail.--deleted--.com.
    Escape character is '^]'.
    +OK Dovecot ready.
    user salespowerchallenge@--deleted--.com
    +OK
    pass --obscured--
    +OK Logged in.
    quit
    +OK Logging out.
    Connection closed by foreign host.

    The mailbox is hosted on Dreamhost. I tried rolling back a version and it didn’t seem to make a difference.

    Suggestions? I am happy to send mailbox credentials to you privately if needed as well as pay for assistance in solving the issue.

    http://wordpress.org/extend/plugins/postie/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Wayne Allen

    (@wayneallen-1)

    Did you try re-entering the password into Postie? Nothing really changed in 1.5 with regards to mail server connectivity.

    Yes – even tried changing the password. I know the new password works. Tested via telnet as well as webmail interface.

    I know there are lots of variables here. I would appreciate any tips on debugging.

    Plugin Author Wayne Allen

    (@wayneallen-1)

    Are you telneting from the same computer WP is installed on?

    Tried both from my laptop as well as using ssh into wp server to try from there.

    I am interested that the pop3 class doesn’t return an actual error message. Is there somewhere that I can change the “timeout” (I did notice that the authentication took a moment from my laptop and no time at all from the server).

    Plugin Author Wayne Allen

    (@wayneallen-1)

    The POP3 class is the same one the WP uses (wp-includes/class-pop3.php) and there is a TIMEOUT attribute which defaults to 60.
    There is also a DEBUG parameter which does some error_log() calls if set to TRUE.

    Thanks for the prompt responses. I am going to persue with my web host to see if something broke there and/or tackle breakpointing the pop3 class to see if I can get some more info on why it fails.

    I’ll update the thread if I find something conclusive.

    Ok – apparently this was a host issue. Things have returned to normal with no changes on my part. So that the good news. The bad news is that I haven’t been able to find out what changed at Dreamhost to make it not work and then work.

    Were you using our email server or gmails?

    Hi Mika, this is on Dreamhost’s side and it turns out that I spoke too soon. It worked for weeks then about a week ago – stopped working. Worked yesterday and now today – not working. This is all on the dili server and homiemail-sub4 servers. All while I haven’t touched the plugin or settings on my side.

    transom – Email me your domain (mika.epstein at dreamhost.com) and I’ll go take your ticket to a mail expert (which I certainly am not). 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Connecting after upgrading to 1.5’ is closed to new replies.