Support » Plugin: FP Foundation Assistant » Conflicts with plugin styles

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author fortpandemonium

    (@fortpandemonium)

    Can you please give me more specific information? What are the issues and the error messages? When do they appear? Try deactivating all plugins and activating them one by one to see which one exactly is causing the conflict.

    Plugin Author fortpandemonium

    (@fortpandemonium)

    If I understand correctly, the conflict happens only on the dashboard pages? Can you please paste the following code in your theme functions.php file and see if the issues persist?

    
    add_action( 'admin_enqueue_scripts', 'plugin_dequeue_scripts' );
    function plugin_dequeue_scripts() {
    
    	$plugin_id = get_current_screen()->id;
    
    	if ( ( $plugin_id != 'settings_page_fp_foundation_assistant_settings' ) && ( $plugin_id != 'post' ) && ( $plugin_id != 'page' ) ) {
    		wp_dequeue_style('fp_foundation_assistant-admin');
    		wp_dequeue_style('fp_foundation_assistant-admin-rtl');
    	}
    
    	if ( $plugin_id != 'settings_page_fp_foundation_assistant_settings' )  {
    		wp_dequeue_script('fp_foundation_assistant-foundation-6');
    	}
    }
    

    The code removes the plugin’s styles and scripts from all pages except the plugin’s options and the new post/page.

    I am currently testing the next plugin release, so I will include the fix in it if everything works fine.

    Correct, it’s only in the dashboard that the issues exist but that seems to have done it! You may want to add that to your code to only enqueue scripts on your screen.

    I’m not using the plugin’s F6 since I have it build into my theme.

    Thank you!

    Plugin Author fortpandemonium

    (@fortpandemonium)

    Thank you for reporting the issue, the fix will be added in the next release.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Conflicts with plugin styles’ is closed to new replies.