Support » Plugin: WP Geo » Conflict with Jetpack/WP Stats

  • Resolved swhale

    (@swhale)


    First, thanks for upgrading to api v3. There seems to be a conflict between WP-Geo and the stats module in Jetpack.

    With just those two plugins enabled the Jetpack Stats graph doesn’t load and the tabs and expansion buttons beneath are disabled. Tested in a couple of browsers. Everything seems fine elsewhere.

    The following appears in the console:

    Uncaught ReferenceError: WPGeo_Admin is not defined admin-post.js:12
    (anonymous function) admin-post.js:12
    l load-scripts.php:2
    c.add load-scripts.php:2
    v.fn.v.ready load-scripts.php:2
    wpgeo_init_admin_post_map

    http://wordpress.org/extend/plugins/wp-geo/

Viewing 11 replies - 1 through 11 (of 11 total)
  • nbostic

    (@nbostic)

    I’m experiencing the same issue, did you ever get yours working?

    swhale

    (@swhale)

    Unfortunately not. I’ve even tried using ‘Plugin Organiser’ to disable WP-Geo whilst on the JetPack stats page, but still get the same error.

    Primitive

    (@primitivenet)

    How are you using WPGeo?

    nbostic

    (@nbostic)

    I have it active. That’s all that’s required to duplicate this issue, WP Geo + Jetpack Stats being activated. I have a fresh 3.5.2 install, running 2012 theme + WP Geo + Jetpack Stats having the issue, along with one of my production sites.

    ratb3rt

    (@ratb3rt)

    Exactly the same here – the only way to view Jetpack stats is to deactivate WP Geo.
    I’m running WP Geo 3.3, WP 3.5.2 and Jetpack 2.3

    I have exactly the same issue.

    WP Geo 3.3, WP 3.6.1 and Jetpack 2.5

    Hi,
    An update on this subject would be much appreciated.
    Emil

    Holy cow, I’ve been having the same issue for some time too!

    Hopefully Ben will find a fix soon.

    Stefano

    Plugin Author Ben Huson

    (@husobj)

    I have create an issue for this. Please follow it and test the fixes here.

    Plugin Author Ben Huson

    (@husobj)

    Issue is resolved by the fix in the above link.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Conflict with Jetpack/WP Stats’ is closed to new replies.