Viewing 4 replies - 1 through 4 (of 4 total)
  • @calvinseng
    WP ERP is fully compatible with PHP7.X, however, its always better to have a backup of your database before upgrading.

    Hi Sultan,

    Thanks but whenever I upgraded to PHP7.X
    It will generate the following error code,

    Warning: Declaration of Illuminate\Database\Eloquent\Collection::contains($key, $value = NULL) should be compatible with Illuminate\Support\Collection::contains($key, $operator = NULL, $value = NULL) in /server_path/plugins/erp/vendor/illuminate/database/Eloquent/Collection.php on line 5
    
    Warning: Declaration of Illuminate\Database\Eloquent\Collection::max($key) should be compatible with Illuminate\Support\Collection::max($callback = NULL) in /server_path/plugins/erp/vendor/illuminate/database/Eloquent/Collection.php on line 5
    
    Warning: Declaration of Illuminate\Database\Eloquent\Collection::min($key) should be compatible with Illuminate\Support\Collection::min($callback = NULL) in /server_path/plugins/erp/vendor/illuminate/database/Eloquent/Collection.php on line 5
    
    Warning: Declaration of Illuminate\Database\Eloquent\Collection::unique() should be compatible with Illuminate\Support\Collection::unique($key = NULL, $strict = false) in /server_path/plugins/erp/vendor/illuminate/database/Eloquent/Collection.php on line 5

    Thank you for pointing this out. We will release a version end of the week fixing those issues.

    @calvinseng,

    I am trying to reproduce this in PHP version 7.2, but no luck!
    Could you please let me know when you are getting this error?
    Also, I’d like to know the current version of your server’s PHP.

    Thanks in advance for your cooperation 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Compatibility with PHP 7.X’ is closed to new replies.