Support » Plugin: Very Simple Contact Form » Compatibility issue with Visual Composer

  • Resolved titsmaker

    (@titsmaker)


    As soon as I have some Visual Composer code on the page your plugin starts to behave strangely – after I hit submit button the page is refreshed but contact form doesn’t disappear, it’s still on the page with all the info typed in, no thank you message.
    If the page is blank or contains some text everything is fine.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Guido

    (@guido07111975)

    Hi,

    I don’t use Visual Composer myself.

    When having a Visual Composer page, is the submission being send to your email? Or absolutely nothing happens?

    And are you able to create a test page for me? And paste the link here?

    Guido

    Thanks for quick reply!
    Submission is being sent, I am getting it into my mail.
    I will provide you with test page later because now my site is under maintenance mode.

    titsmaker

    (@titsmaker)

    Is there a way to send you a link for test purposes privately?

    Plugin Author Guido

    (@guido07111975)

    Hi,

    Do you have a website with contact data?
    I don’t.. but am willing to add a temp contact form so you can send me a message.

    Guido

    titsmaker

    (@titsmaker)

    OK, I’d better just send it here without all the hassle. By the way it’s stupid WP forums don’t have private messages functionality…
    Here is a page with only your contact form in body – https://artifactoria.com/contact-test-without-vc/
    And here with some text inserted via VC block – https://artifactoria.com/contact-test-with-vc/

    Plugin Author Guido

    (@guido07111975)

    Hi,

    Have send you a test message via both forms.. I notice the VC page somehow blocks the Javascript that is being used to redirect to the success page.. it should add ?vscfsp=success to the page-URL and this is not happening at the VC page.

    Because VC is a premium plugin, you can consider creating a support thread there as well.

    Guido

    titsmaker

    (@titsmaker)

    I am getting messages from both pages. So you think the error is caused by VC?

    Plugin Author Guido

    (@guido07111975)

    Guess so, because the only part that isn’t working is the Javascript redirect.
    So VC might have disabled or blocked Javascript inside their container.

    Best thing to do for now is ask them. Are you able/willing to do that? Guess you have access to VC support?

    Guido

    titsmaker

    (@titsmaker)

    VC is bundled with my theme, I will try to contact them, although I doubt they will dive into this issue.

    Plugin Author Guido

    (@guido07111975)

    Hi,

    I have installed VC (WPbakery) myself and having the same issue. The Javascript redirect isn’t working after sending fails or succeeds. I inserted the shortcode directly on a page, and via the “Shortcode Mapper” of WPbakery.

    Because I don’t have an account there, I would really appreciate if you are willing to open a thread there. I advice you to add the link of this thread for reference.

    Guido

    titsmaker

    (@titsmaker)

    Unfortunately I don’t have access to their support because VC was bundled with theme, I will try to contact theme authors and ask them to pass this issue to VC support.

    Plugin Author Guido

    (@guido07111975)

    Hi @titsmaker

    I think I’ve found a fix for this issue, are you willing to double-check this after I’ve updated plugin?

    Guido

    titsmaker

    (@titsmaker)

    Great. I’ve just checked and it works as expected now.

    Plugin Author Guido

    (@guido07111975)

    Great, thanks for letting me know. I mark this thread as resolved.

    Guido

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.