Support » Theme: Smartline Lite » Compatibility error

Viewing 7 replies - 1 through 7 (of 7 total)
  • Theme Author ThemeZee

    (@themezee)

    Hi there,

    Thanks for using Smartline.

    You have to be more specific and provide an URL to your website with the popup.

    And usually plugins have to make sure that they use their own namespace for styling, not the theme. So in most cases, the plugin styling has to be fixed, not the theme styling.

    Best,
    Thomas

    The link above is very specific, and gives you the reason why I posted this here after having posted to the plugin forum. Did you actually follow it?
    This test page https://www.mpba.org.uk/ztest-popup/. The popup is supposed to look like the 2nd one

    • This reply was modified 3 months, 3 weeks ago by  mpbaweb.
    • This reply was modified 3 months, 3 weeks ago by  mpbaweb.
    Theme Author ThemeZee

    (@themezee)

    Ah, sorry I missed the links in that page.

    Smartline is a very old theme and only adds paragraph styling to the normal post content, but uses a CSS reset everywhere else.

    Therefore there is no default styling for the popup, like spacing between paragraphs. You have to add your own styling with CSS code for the popup.

    Best,
    Thomas

    Ok. How do I do that?

    Theme Author ThemeZee

    (@themezee)

    This might sound silly, but you have to ask the plugin developers again.

    They can tell you which classes and IDs there HTML code uses which you need to add some spacing.

    Another alternative is to switch to one of our newer themes, which does not work with CSS resets.

    Best,
    Thomas

    No, what is silly is your ‘CSS Reset’ whatever that is. Please update the Theme to current standards.

    Theme Author ThemeZee

    (@themezee)

    Yes, I totally agree. Smartline was developed in 2014 and we have long switched to CSS normalization for our newer themes.

    However, we do not update the theme and never have, because changing the CSS would possibly break a lot of customizations and child themes.

    Sorry that I’m not able to provide a better answer here. You can always switch to a newer theme which isn’t 4 years old 🙂

    Best,
    Thomas

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.