Support » Fixing WordPress » Comments not showing

Viewing 9 replies - 1 through 9 (of 9 total)
  • That doesn’t help. I’m not moderating the comments, so they should be showing up, right?

    TechGnome

    (@techgnome)

    Moderator

    In your template, there should be a div tag with class=”feedback” set. 1) Is it there? and 2) what is in it?
    Example, mine looks like this:
    <div class="feedback">
    <?php link_pages('
    Pages: ', '
    ', 'number'); ?>
    <?php $my_post_tile = the_title('', '', FALSE); ?>
    <?php comments_popup_link('No comments about "'.$my_post_tile.'"', 'One comment about "'.$my_post_tile.'"', '% Comments about "'.$my_post_tile.'"', '', 'Please, no more comments.'); ?>
    </div>

    Yours should look like this:
    <div class="feedback">
    <?php link_pages('
    Pages: ', '
    ', 'number'); ?>
    <?php comments_popup_link('Comments (0)', 'Comments (1)', 'Comments (%)', '', 'Please, no more comments.'); ?>
    </div>

    TG

    Have you compared what you have on the site to what was in the original WP file ?
    It seems to me there may be a difference ?

    TechGnome, except for the ”, ‘Please, no more comments.’ part, that is EXACTLY what my coding looks like right there.
    podz, I’ve been trying to compare the original WP file, but I can’t find any differences when it comes to the comments section.

    TechGnome

    (@techgnome)

    Moderator

    Ok, after that DIV tag, there should be some code for the trackback RDF, then this line:
    <?php include(ABSPATH . 'wp-comments.php'); ?>
    It seems that’s what actually prints out the comments. I double checked the source from my site, and comments are after the RDF data, which is where that code falls.
    Double check to make sure that is still in your template.
    TG

    That’s still in my template.

    TechGnome

    (@techgnome)

    Moderator

    Hmmm…. interesting…. It says there are 4 comments (on one of the posts), when I click it though…. it says “No comments”….. something isn’t right.
    1) Have you installed any hacks of any kind?
    2) Try getting a new copy of wp-comments.php and see what happens.
    3) Check your options and make sure that the URL for the site is right (that is is fuzzypinkslippers.com and not http://www.fuzzypinkslippers.com)
    TG

    Could it have anything at all to do with my not including all of the original css (from wp-layout.css)?

    hi, i think i messed up somewhere. i accidentally deleted my user ID (the one i imported from MT) and all the posts disappeared. what i did is to export from MT and import again in WP, but my comments kinda messed up, it doesn’t show on my index page and even while i Edit the entries, however i can view it in Edit Comments [Latest Comments]. can somebody help me please? Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Comments not showing’ is closed to new replies.