Support » Plugin: oAuth Twitter Feed for Developers » Check for existing classes

  • Resolved nielsvanrenselaar

    (@nielsvanrenselaar)


    in oauth/OAuth.php you should check if classes are already decleared, because OAuth is pretty generic and widely used; or you should prepend it with a prefix.

    <?php
    
    /* Generic exception class
    */
    
    if( !class_exists("OAuthException") ) {
    	class OAuthException extends Exception {
    	  // pass
    	}
    }
    
    ?>

    This solved the problem:

    Fatal error: Cannot redeclare class OAuthException in /home/bemore/domains/be-more.nl/public_html/wordpress/wp-content/plugins/oauth-twitter-feed-for-developers/oauth/OAuth.php on line 8

    http://wordpress.org/plugins/oauth-twitter-feed-for-developers/

Viewing 1 replies (of 1 total)
  • Plugin Author Liam Gladdy

    (@lgladdy)

    Version 2.2 adds proper compatibility with OAuth or TwitterOAuth being included by another plugin, or built into PHP/included by PECL.

Viewing 1 replies (of 1 total)
  • The topic ‘Check for existing classes’ is closed to new replies.