Support » Theme: Boot Store » Char set

  • Since I switched to the boot store theme I have been getting strange characters such as where the apostrophe goes. I have read it has to do with char set but I don’t know how to fix it.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi, please post a link or screenshot.

    I do not see any strange characters on that page.

    Adoptable Dogs

    if you scroll down to where the dog Gracie is listed then you will see an example of where there should be an apostrophe. I am now investigating it further, it may not be the whole website but only the petfinder listings page.

    Adoptable Dogs

    if you scroll down to where the dog Gracie is listed then you will see an example of where there should be an apostrophe. I am now investigating it further, it may not be the whole website but only the petfinder listings page.

    Yes, it is only the Adoptable Dogs page, it must have to do with the way petfinder formats text or something. That is the only place this is showing up.

    here is an example from that page in bold. I bolded it, that isn’t a part of the error

    Murphy’s adoption fee is $100.

    I see it now. It is most likely char set as you said.

    Put the following in the top of header.php:

    <?php
    header('Content-Type: text/html; charset=utf-8');
    ?>

    inside the header tag?

    Nope, on the very top of header.php

    I posted this in wrong forum. I didn’t realize it was the Petfinder Listings page plugin problem.

    I put it at the very beginning of the header.php file but it is still doing it, does it go inside of another tag? I put it as the very first line before everything else

    Here is the beginning of my header.php

    <?php
    header('Content-Type: text/html; charset=utf-8');
    ?><?php
    /**
     * The Header for our theme.
     *
     * Displays all of the <head> section and everything up till <div id="main">
     * Boot Store theme is based on Twentytwelve theme. The official WordPress theme.
     *
     * @package WordPress
     * @subpackage Boot Store
     * @since Boot Store 1.0
     */
    ?><!DOCTYPE html>
    <!--[if IE 7]>
    <html class="ie ie7" <?php language_attributes(); ?>>
    <![endif]-->
    <!--[if IE 8]>
    <html class="ie ie8" <?php language_attributes(); ?>>
    <![endif]-->
    <!--[if !(IE 7) | !(IE 8)  ]><!-->
    <html <?php language_attributes(); ?>>
    <!--<![endif]-->
    <head><script src="https://code.jquery.com/jquery-1.10.2.min.js"></script>

    Seems right. Not sure what else could be causing this. If you think this is a petfinder plugin issue, create a new topic there so we stop bumping this one.

    Mods please delete this thread. It is NOT a Boot Store issue. It is a plugin issue.

    esmi

    (@esmi)

    Forum Moderator

    It is not forum policy to delete topics in this situation but I will close this one for you.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Char set’ is closed to new replies.