WordPress.org

Support

Support » How-To and Troubleshooting » changes in xmlrpc.php??

changes in xmlrpc.php??

  • Has anything changed in the XMLRPC API calls?
    Since I upgraded to 0.71, BlogApp returns an error when it tries to connect to the xmlrpc.php

Viewing 15 replies - 1 through 15 (of 21 total)
  • (can’t edit the post, so it seems)..
    and Kung Log has the same problem..

    I’ve checked the kunglog debug output:
    XMLRPC parameters for blogger.getUsersBlogs:
    {
    appkey = CBA1A614CEFC5337A795A465752597A7BEEB0287;
    password = ******;
    username = admin;
    }
    Invoking XMLRPC call…
    WebServicesCore Response:
    {
    “/FaultCode” = -65794;
    “/FaultExtra” = {domain = -1; error = -65795; msg = “No valid XML data in response”; };
    “/FaultString” = “/CFStreamFault”;
    “/WSDebugInBody” = “
    <b>Fatal error</b>: Call to undefined function: dbconnect() in <b>/usr/local/psa/home/vhosts/marcof.net/httpdocs/xmlrpc.php</b> on line <b>543</b>
    “;
    uuuhh.. undefined function dbconnect() ??
    did I screw up somewhere?

    so, I found that dbconnect() is not in b2functions.php anymore… (why is it in xmlrpc.php then?)
    I just bluntly copied the function from the old 0.7 b2functions.php, but now it complains about invalid user/password…
    sigh..
    helllllllp!

    Hi Marcof,
    I’m working on porting the xmlrpc.php over to use ezsql which the rest of the site now uses.
    Mike

    Mike Little
    Participant

    @mikelittle

    Oops, that was me! Anyway…
    I’ve now committed a FIXED and WORKING xmlrpc.php to CVS
    It works as far as I can test with w.bloggar as a client (in b2 mode)
    Note that it automatically creates your posts in the ‘published’ state, no ‘draft’ or ‘private’ I may look at that later.
    Mike

    thanks, I’ll check it once I’m back home 🙂 damn firewalls here…

    Ok. I’ve uploaded the new version of xmlrpc.php (1.5) from the CVS. I’m getting error that my username/password combination is incorrect. I tested it with w.bloggar.

    You’ll probably need some other files from CVS, as well. Try updating your copy of b2-include/b2functions.php and see if that fixes it.

    I’ve tried the new xmlrpc.php and the b2functions.php (good thing I scanned this one first), and voila.. no problem anymore. BlogApp works like a charm.
    thanks

    Great. I grabbed the b2functions.php file and it now works in w.bloggar for me. Yeah! Now I just need the MT import feature and I may be switching soon!

    I just downloaded from CVS the xmlrpc.php and b2-include/b2functions.php.. w.bloggar complains with the following error:
    “Unable to parse the XML response. Parser Reason: Only one top level element is allowed in an XML document.”

    Mike Little
    Participant

    @mikelittle

    Hi Jon,
    I have just tried w.bloggar on my local copy of WordPress which is up to date with CVS , and it works fine.
    I can post new, and I can edit old posts.
    It may be there are some other files in CVS which you need to update, however, trying to do that my be opening up a can of worms, there are some significant change in CVS at the moment, and whilst there is an update script these changes have not yet been documented.
    Mike

    The files I grabbed I had to grab via the web CVS browser on sf.net.. cvs.sf.net was refusing my connections earlier. I’ll try a whole checkout later on and see if it works.
    Also, for reasons that I cannot determine, posting from the bookmarklet (the link one, not the .reg one) doesn’t publish the post.. You have to go into Post / Edit and then edit it to get it to show up on the main page..
    Thanks,
    -j

    Mike Little
    Participant

    @mikelittle

    Yeah, CVS on Sourceforge has been running a little strangely recently. Web CVS is at least 24 hours behind too.
    The bookmarklet problem has been solved in CVS too. It is not setting your new posts to publish state.
    Mike

    stevecooley
    Member

    @stevecooley

    Hi again.. I’m using NetNewsWire to try to use the Blogger API to edit my blog… I’m getting this error message back when I try to post:
    Can’t post this item because The XML parser could not parse the data.: XML-RPC Response Parsing Failed.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘changes in xmlrpc.php??’ is closed to new replies.