WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Change configuration to point to localhost

[Resolved] Change configuration to point to localhost

  • factchecker
    Participant

    @factchecker

    Hello. Trying to get moved from shared hosting to VPS for a week. I got this email from support now, and can’t figure out what to change:

    I am seeing that your site is now resolving correctly. It may still take a bit on your end. I noticed that there was a database error when I looked at it on the wordpress blog. Make sure you change the configuration to point to localhost for your database, as it looks like it might be looking at a remote server.

    I have VPS Manager, Cpanel, and WHM links. Any idea which one is the place I need to go. Can’t find it in any of them, but I am quite jittery at this point and may be overlooking the obvious. Thanks.

    http://idolstages.com

Viewing 7 replies - 1 through 7 (of 7 total)
  • That would be in your WordPress files. Check your specifications in your wp-config.php file — that’s where you specify the name and location of the database.

    paulgweb
    Member

    @paulgweb

    Are you referring to the setting needed in “install.php” ?

    paulgweb
    Member

    @paulgweb

    I see, your script is complaining: “or we can’t contact the database server at remotemysqlhost.”

    maybe your host was saying to change the install.php server address to “localhost”

    paulgweb
    Member

    @paulgweb

    Hi DianeV – looks like we both replied at the same time… and said the same thing. Can you look at my support question too?

    paulgweb, I’m not quite sure what your question was, but based upon what you said (and I’ve not dealt with the WP 2.x versions):

    – the database specifications are in wp-config.php
    – there are no settings to be set in install.php; you just input the database data in wp-config.php, and then run install.php

    Does that help?

    factchecker
    Participant

    @factchecker

    the database specifications are in wp-config.php

    Thank you SO much. That localhost advice was what I needed. Smiling again for the first time in a week.

    Excellent!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Change configuration to point to localhost’ is closed to new replies.