WordPress.org

Support

Support » Themes and Templates » Cant see theme in Admin Panel

Cant see theme in Admin Panel

  • I was looking around my themes in the control panel and noticed that I no longer see settings etc for my current active theme (Constructor). My site is working fine using the theme, and the folder is there along with about 7 other themes, but I only see the 7 themes in the themes section. I discovered this while playing with a sandbox version of my site. I wanted to see how it looked with another theme before committing and found that I could not change it back to constructor as it did not show in the thumbnails presented. Any ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Update: I found that when I click on Themes on the toolbar, the screen quickly shows the active theme (constructor) at the top left and I see the theme count = 11, but within a second, it refreshes and the active theme is no longer there and the count is 10. It is as if WP is filtering out showing the active theme in this section. When I choose customize, I can see constructor.

    esmi

    @esmi

    Forum Moderator

    Can you replicate the problem using the default Twenty Fourteen theme with all plugins deactivated?

    I am reluctant to turn off all plugins after reading other nightmares folks had when doing the same. Is there another way to test this?

    esmi

    @esmi

    Forum Moderator

    There is no magic bullet in these situations. This is just the start of basic troubleshooting and is a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps.

    Your theme & plugin settings are saved in your database and should be retained for future use.

    Ok. I’ll give it a try and report back.

    Just did it. Disabled all plugins, switched theme to 2014. Result:
    – site shows 2014
    – Appearance shows 2014 as active theme.
    – Themes does not show Constructor theme as an available theme to use. all other themes show.

    esmi

    @esmi

    Forum Moderator

    Sounds like there is a problem in your copy of the Constructor theme. Try deleting that theme and then re-uploading it.

    So I deleted the theme and reinstalled it, and it still does not show. Im giving up as I think its an issue with the theme (Constructor). One thing I noticed is that Constructor has some files and folders in my Uploads folder, but any other theme seems to keep all its files in the themes folder. I did have some heade4 customization, but figured it would have worked after deleting and recreating.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Cant see theme in Admin Panel’ is closed to new replies.
Skip to toolbar