Support » Fixing WordPress » Can't login, receiving Internal Server Error

  • Resolved John

    (@crazsixstring27)


    This is the message I received…

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@chestnutgroove.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    I know what I did. I changed the url from mydomain.com to my domain.com/home, and now I got locked out. Every time I try to login as admin, I get that message.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator James Huff

    (@macmanx)


    Internal server errors (error 500) are often caused by plugin or theme function conflicts, so if you have access to your admin panel, try deactivating all plugins. If you don’t have access to your admin panel, try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Fifteen theme to rule-out a theme-specific issue. If you don’t have access to your admin panel, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue.

    If that does not resolve the issue, it’s possible that a .htaccess rule could be the source of the problem. To check for this, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and rename the .htaccess file. If you can’t find a .htaccess file, make sure that you have set your SFTP or FTP client to view invisible files.

    If you weren’t able to resolve the issue by either resetting your plugins and theme or renaming your .htaccess file, we may be able to help, but we’ll need a more detailed error message. Internal server errors are usually described in more detail in the server error log. If you have access to your server error log, generate the error again, note the date and time, then immediately check your server error log for any errors that occurred during that time period. If you don’t have access to your server error log, ask your hosting provider to look for you.

    John

    (@crazsixstring27)


    http://12.345.67.891/home is what I renamed my website in the general settings area. I was just http://12.345.67.891. That is what the confusion is. It locked me out the second I saved the changes and refreshed the page.

    I am also very new to all of this stuff so I have NO IDEA what I’m doing with the SFTP or FTP or anything like that. I was slowly just learning WordPress….

    Please be patient.

    Also if go to http://12.345.67.891/wp-login.php I get a weird login page that I can’t get past without seeing the error message.

    If I go straight to http://12.345.67.891/home/wp-login.php, I get the error message right away.

    Moderator James Huff

    (@macmanx)


    Follow this guide: https://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

    You’ll need to change the siteurl and home values directly in the database back to:

    http://12.345.67.891

    You’ll find phpMyAdmin in your hosting account’s control panel.

    When you’re ready to move the site, follow this guide: https://codex.wordpress.org/Moving_WordPress#Moving_Directories_On_Your_Existing_Server

    John

    (@crazsixstring27)


    ok I am into the wordpress admin dashboard now but when I log into my https://wordpress.com/me/account, my site(http://12.345.67.891) that was connected to that account is not connected anymore and it’s saying I have to make a new site even though I have access again to the admin dash.

    Moderator James Huff

    (@macmanx)


    From the My Jetpack sub-section of your Dashboard’s Jetpack section, please try disconnecting from and reconnecting to WordPress.com.

    John

    (@crazsixstring27)


    Thank you!!! Everything is back to the way it was.

    One quick question while I have the thread open. I am trying to open up the header image size so it can reveal the background. Problem is I can only seem to do this for every single page. I just want it to be on the landing page which has no page title after the domain.

    This code does exactly what I want, but it affects all pages and not just the homepage.

    .header {
        height: 1500px;
    }
    
    .header,
    .header-content-wrap,
    .packages,
    .contact-us {
        background: none repeat scroll 0% 0% rgba(0, 0, 0, 0) !important;
    }

    This code doesn’t work at all.

    .home .header {
        height: 1500px;
    }
    
    .home .header,
    .header-content-wrap,
    .packages,
    .contact-us {
        background: none repeat scroll 0% 0% rgba(0, 0, 0, 0) !important;
    }
    Moderator James Huff

    (@macmanx)


    What’s the name of the theme you’re using?

    John

    (@crazsixstring27)


    Zerif Pro

    Moderator James Huff

    (@macmanx)


    Ok, since that’s a commercial theme, I recommend asking over at http://themeisle.com/forums/

    I won’t be able to figure out what’s happening without purchasing the theme myself, but they have a direct way to get support for the theme’s designers themselves. 🙂

    John

    (@crazsixstring27)


    Okay. Thank you so much. You have been really helpful, and I was able to fix everything I asked about. Marked as resolved.

    Enjoy the rest of your day,
    John

    Moderator James Huff

    (@macmanx)


    You’re welcome!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.